<!DOCTYPE html><html lang="en"><head><meta charSet="utf-8"/><meta http-equiv="x-ua-compatible" content="ie=edge"/><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"/><style data-href="/styles.d55f0b00584a849e5a53.css" id="gatsby-global-css">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</style><meta name="generator" content="Gatsby 2.31.1"/><style data-styled="snXzu  dHFJiE juhqmw emkjqm gXdVsZ bNBvDS krfJjt dcCAoE bOFCvB hWelvs chuSjW gfsFHC hPiWwP dpxSoa cWnjEm dYwfEO ccYauZ dKPMHb comtIp ctVXnp gIUzxO bPAwul jCTJvb dxCDWd bSmbcb cuYzWk lmdzyt jmtVcB hOucDX jPtpSf cieZjZ bGXQre bKLyNE" data-styled-version="4.4.1">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</style><style type="text/css">
    .anchor {
      float: left;
      padding-right: 4px;
      margin-left: -20px;
    }
    h1 .anchor svg,
    h2 .anchor svg,
    h3 .anchor svg,
    h4 .anchor svg,
    h5 .anchor svg,
    h6 .anchor svg {
      visibility: hidden;
    }
    h1:hover .anchor svg,
    h2:hover .anchor svg,
    h3:hover .anchor svg,
    h4:hover .anchor svg,
    h5:hover .anchor svg,
    h6:hover .anchor svg,
    h1 .anchor:focus svg,
    h2 .anchor:focus svg,
    h3 .anchor:focus svg,
    h4 .anchor:focus svg,
    h5 .anchor:focus svg,
    h6 .anchor:focus svg {
      visibility: visible;
    }
  </style><script>
    document.addEventListener("DOMContentLoaded", function(event) {
      var hash = window.decodeURI(location.hash.replace('#', ''))
      if (hash !== '') {
        var element = document.getElementById(hash)
        if (element) {
          var offset = element.offsetTop
          // Wait for the browser to finish rendering before scrolling.
          setTimeout((function() {
            window.scrollTo(0, offset - 80)
          }), 0)
        }
      }
    })
  </script><link rel="alternate" type="application/rss+xml" title="HTTP Toolkit RSS Feed" href="/rss.xml"/><title data-react-helmet="true">Build an HTTPS-intercepting JavaScript proxy in 30 seconds flat | HTTP Toolkit</title><link data-react-helmet="true" rel="dns-prefetch" href="https://fonts.googleapis.com"/><link data-react-helmet="true" rel="preconnect" href="https://fonts.gstatic.com"/><link data-react-helmet="true" rel="preconnect" href="https://checkout.paddle.com"/><link data-react-helmet="true" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Lato|Courgette"/><link data-react-helmet="true" rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png"/><link data-react-helmet="true" rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png"/><link data-react-helmet="true" rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png"/><link data-react-helmet="true" rel="manifest" href="/site.webmanifest"/><link data-react-helmet="true" rel="mask-icon" href="/safari-pinned-tab.svg" color="#e1421f"/><link data-react-helmet="true" rel="alternate" type="application/rss+xml" href="https://httptoolkit.tech/rss.xml"/><meta data-react-helmet="true" name="msapplication-TileColor" content="#da532c"/><meta data-react-helmet="true" name="theme-color" content="#fafafa"/><meta data-react-helmet="true" name="viewport" content="width=device-width, initial-scale=1"/><meta data-react-helmet="true" property="og:url" content="https://httptoolkit.tech/blog/javascript-mitm-proxy-mockttp/"/><meta data-react-helmet="true" property="og:type" content="website"/><meta data-react-helmet="true" name="twitter:site" content="@httptoolkit"/><meta data-react-helmet="true" name="twitter:creator" content="@pimterry"/><meta data-react-helmet="true" name="description" content="HTTP(S) is the glue that binds together modern architectures, passing requests between microservices and connecting web &amp; mobile apps alike…"/><meta data-react-helmet="true" property="og:title" content="Build an HTTPS-intercepting JavaScript proxy in 30 seconds flat"/><meta data-react-helmet="true" property="og:description" content="HTTP(S) is the glue that binds together modern architectures, passing requests between microservices and connecting web &amp; mobile apps alike…"/><meta data-react-helmet="true" property="og:image" content="https://httptoolkit.tech/static/1db77a76a9b6781e795b113b665af148/3c289/network.jpg"/><meta data-react-helmet="true" name="twitter:card" content="summary_large_image"/><meta data-react-helmet="true" name="twitter:title" content="Build an HTTPS-intercepting JavaScript proxy in 30 seconds flat"/><meta data-react-helmet="true" name="twitter:description" content="HTTP(S) is the glue that binds together modern architectures, passing requests between microservices and connecting web &amp; mobile apps alike…"/><meta data-react-helmet="true" name="twitter:image" content="https://httptoolkit.tech/static/1db77a76a9b6781e795b113b665af148/3c289/network.jpg"/><script data-react-helmet="true" type="application/ld+json">{"@context":"https://schema.org","@type":"SoftwareApplication","image":"https://httptoolkit.tech/logo-square.png","screenshot":"https://httptoolkit.tech/screenshot.png","video":"https://httptoolkit.tech/http-mock-demo.mp4","name":"HTTP Toolkit","description":"Beautiful & open-source tools to debug, test and develop with HTTP(S)","softwareVersion":"1.3.0","operatingSystem":["Windows","Mac","Linux","Android"],"url":"https://httptoolkit.tech/","downloadUrl":"https://httptoolkit.tech/","applicationCategory":"DeveloperApplication","offers":{"@type":"Offer","price":"0"}}</script><style data-react-helmet="true">
    /* latin */
    @font-face {
        font-family: 'Lato';
        font-style: normal;
        font-weight: 400;
        src: local('Lato Regular'), local('Lato-Regular'), url(https://fonts.gstatic.com/s/lato/v14/S6uyw4BMUTPHjx4wXg.woff2) format('woff2');
        unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
    }

    /* latin */
    @font-face {
        font-family: 'Merriweather';
        font-style: normal;
        font-weight: 400;
        src: local('Merriweather Regular'), local('Merriweather-Regular'), url(https://fonts.gstatic.com/s/merriweather/v21/u-440qyriQwlOrhSvowK_l5-fCZM.woff2) format('woff2');
        unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
    }

    /* latin */
    @font-face {
        font-family: 'Courgette';
        font-style: normal;
        font-weight: 400;
        src: local('Courgette Regular'), local('Courgette-Regular'), url(https://fonts.gstatic.com/s/courgette/v5/wEO_EBrAnc9BLjLQAUk1VvoK.woff2) format('woff2');
        unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
    }

    /* latin-ext */
    @font-face {
        font-family: 'Lato';
        font-style: normal;
        font-weight: 400;
        src: local('Lato Regular'), local('Lato-Regular'), url(https://fonts.gstatic.com/s/lato/v14/S6uyw4BMUTPHjxAwXjeu.woff2) format('woff2');
        unicode-range: U+0100-024F, U+0259, U+1E00-1EFF, U+2020, U+20A0-20AB, U+20AD-20CF, U+2113, U+2C60-2C7F, U+A720-A7FF;
    }

    /* latin-ext */
    @font-face {
        font-family: 'Merriweather';
        font-style: normal;
        font-weight: 400;
        src: local('Merriweather Regular'), local('Merriweather-Regular'), url(https://fonts.gstatic.com/s/merriweather/v21/u-440qyriQwlOrhSvowK_l5-ciZMZ-Y.woff2) format('woff2');
        unicode-range: U+0100-024F, U+0259, U+1E00-1EFF, U+2020, U+20A0-20AB, U+20AD-20CF, U+2113, U+2C60-2C7F, U+A720-A7FF;
    }
</style><link rel="preconnect dns-prefetch" href="https://www.google-analytics.com"/><link rel="sitemap" type="application/xml" href="/sitemap.xml"/><link rel="canonical" href="https://httptoolkit.tech/blog/javascript-mitm-proxy-mockttp/" data-baseprotocol="https:" data-basehost="httptoolkit.tech"/><link rel="stylesheet" href="https://cdn.jsdelivr.net/npm/docsearch.js@2/dist/cdn/docsearch.min.css"/><link as="script" rel="preload" href="/webpack-runtime-0e40374d4b17de076b79.js"/><link as="script" rel="preload" href="/framework-55e583128ea4f6d463ba.js"/><link as="script" rel="preload" href="/app-fd83417bb9d1609e371b.js"/><link as="script" rel="preload" href="/styles-e9d24b1846c7d6eb9685.js"/><link as="script" rel="preload" href="/commons-c8c9d5538099db54b82e.js"/><link as="script" rel="preload" href="/619566e31416cc598d6f6877812c0979622af6dd-b74d74a440dbc9f605f0.js"/><link as="script" rel="preload" href="/component---src-templates-post-jsx-91e87be856aa7dfd57f4.js"/><link as="fetch" rel="preload" href="/page-data/blog/javascript-mitm-proxy-mockttp/page-data.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/page-data/app-data.json" crossorigin="anonymous"/></head><body><div id="___gatsby"><div style="outline:none" tabindex="-1" id="gatsby-focus-wrapper"><main class="sc-kAzzGY snXzu"><div class="sc-bdVaJa dHFJiE"><div class="sc-bwzfXH juhqmw"><div class="sc-htpNat emkjqm"><a class="sc-chPdSV gXdVsZ" href="/"><img src="https://d33wubrfki0l68.cloudfront.net/bf336c12f88430c817226c3a390b970ab29ea5ac/d4a5d/static/logo-5658def669bc8a94ba3d97f752342bd4.svg" alt="HTTP Toolkit"/></a><a href="#menu" class="sc-kGXeez bNBvDS"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="bars" class="svg-inline--fa fa-bars fa-w-14 fa-2x " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M16 132h416c8.837 0 16-7.163 16-16V76c0-8.837-7.163-16-16-16H16C7.163 60 0 67.163 0 76v40c0 8.837 7.163 16 16 16zm0 160h416c8.837 0 16-7.163 16-16v-40c0-8.837-7.163-16-16-16H16c-8.837 0-16 7.163-16 16v40c0 8.837 7.163 16 16 16zm0 160h416c8.837 0 16-7.163 16-16v-40c0-8.837-7.163-16-16-16H16c-8.837 0-16 7.163-16 16v40c0 8.837 7.163 16 16 16z"></path></svg></a><nav id="menu" class="sc-kgoBCf krfJjt"><button class="sc-fjdhpX bOFCvB sc-kpOJdX dcCAoE"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="times" class="svg-inline--fa fa-times fa-w-11 fa-2x " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 352 512"><path fill="currentColor" d="M242.72 256l100.07-100.07c12.28-12.28 12.28-32.19 0-44.48l-22.24-22.24c-12.28-12.28-32.19-12.28-44.48 0L176 189.28 75.93 89.21c-12.28-12.28-32.19-12.28-44.48 0L9.21 111.45c-12.28 12.28-12.28 32.19 0 44.48L109.28 256 9.21 356.07c-12.28 12.28-12.28 32.19 0 44.48l22.24 22.24c12.28 12.28 32.2 12.28 44.48 0L176 322.72l100.07 100.07c12.28 12.28 32.2 12.28 44.48 0l22.24-22.24c12.28-12.28 12.28-32.19 0-44.48L242.72 256z"></path></svg></button><a class="sc-dxgOiQ hWelvs" href="/docs/">Docs</a><a class="sc-dxgOiQ hWelvs" href="/pricing/">Pricing</a><a class="sc-dxgOiQ hWelvs" href="/blog/">Blog</a><a class="sc-dxgOiQ hWelvs" href="/contact/">Contact</a></nav></div></div></div><section width="780px" class="sc-ckVGcZ sc-jeCdPy chuSjW"><article class="sc-bGbJRg gfsFHC"><div class="sc-bEjcJn hPiWwP gatsby-image-wrapper" style="position:relative;overflow:hidden"><div style="width:100%;padding-bottom:22.34375%"></div><img src="data:image/jpeg;base64,/9j/2wBDABALDA4MChAODQ4SERATGCgaGBYWGDEjJR0oOjM9PDkzODdASFxOQERXRTc4UG1RV19iZ2hnPk1xeXBkeFxlZ2P/2wBDARESEhgVGC8aGi9jQjhCY2NjY2NjY2NjY2NjY2NjY2NjY2NjY2NjY2NjY2NjY2NjY2NjY2NjY2NjY2NjY2NjY2P/wgARCAAEABQDASIAAhEBAxEB/8QAFgABAQEAAAAAAAAAAAAAAAAAAAME/8QAFAEBAAAAAAAAAAAAAAAAAAAAAv/aAAwDAQACEAMQAAABjnApBn//xAAYEAACAwAAAAAAAAAAAAAAAAAAAREhMf/aAAgBAQABBQJ5Nn//xAAVEQEBAAAAAAAAAAAAAAAAAAACEP/aAAgBAwEBPwFT/8QAFBEBAAAAAAAAAAAAAAAAAAAAEP/aAAgBAgEBPwE//8QAFBABAAAAAAAAAAAAAAAAAAAAEP/aAAgBAQAGPwJ//8QAFxABAQEBAAAAAAAAAAAAAAAAAQARIf/aAAgBAQABPyFdQmK7f//aAAwDAQACAAMAAAAQjA//xAAWEQADAAAAAAAAAAAAAAAAAAABEDH/2gAIAQMBAT8QoL//xAAWEQEBAQAAAAAAAAAAAAAAAAABEDH/2gAIAQIBAT8QMZ//xAAaEAEAAwADAAAAAAAAAAAAAAABABEhQVGx/9oACAEBAAE/EF2BqjeqiAarfIJA8z//2Q==" alt="" style="position:absolute;top:0;left:0;width:100%;height:100%;object-fit:cover;object-position:center;opacity:1;transition-delay:500ms"/><noscript><picture><source type='image/webp' srcset="https://d33wubrfki0l68.cloudfront.net/9983fbf5461d9d0aa3c962e810e1490a3358468e/24a39/static/1db77a76a9b6781e795b113b665af148/97a54/network.webp 640w,
https://d33wubrfki0l68.cloudfront.net/4034e4367c8a925c1f76948511d088217e43449d/79afa/static/1db77a76a9b6781e795b113b665af148/fad22/network.webp 1280w,
https://d33wubrfki0l68.cloudfront.net/ec693c5655767bcd9c25b4410894f162a96cc33a/e1f13/static/1db77a76a9b6781e795b113b665af148/d829f/network.webp 2000w" sizes="(max-width: 2000px) 100vw, 2000px" /><source srcset="https://d33wubrfki0l68.cloudfront.net/4e4d1f6e9d9da2b957ce4d4c728742f7f5d86c28/968af/static/1db77a76a9b6781e795b113b665af148/b67a5/network.jpg 640w,
https://d33wubrfki0l68.cloudfront.net/2e3159b4dd15fa39805289b12985d99982d1df95/32d76/static/1db77a76a9b6781e795b113b665af148/684d9/network.jpg 1280w,
https://d33wubrfki0l68.cloudfront.net/6a8895ff5f14ed0a38e4a6424448ab7730464c50/1ccd8/static/1db77a76a9b6781e795b113b665af148/469fe/network.jpg 2000w" sizes="(max-width: 2000px) 100vw, 2000px" /><img loading="eager" sizes="(max-width: 2000px) 100vw, 2000px" srcset="https://d33wubrfki0l68.cloudfront.net/4e4d1f6e9d9da2b957ce4d4c728742f7f5d86c28/968af/static/1db77a76a9b6781e795b113b665af148/b67a5/network.jpg 640w,
https://d33wubrfki0l68.cloudfront.net/2e3159b4dd15fa39805289b12985d99982d1df95/32d76/static/1db77a76a9b6781e795b113b665af148/684d9/network.jpg 1280w,
https://d33wubrfki0l68.cloudfront.net/6a8895ff5f14ed0a38e4a6424448ab7730464c50/1ccd8/static/1db77a76a9b6781e795b113b665af148/469fe/network.jpg 2000w" src="https://d33wubrfki0l68.cloudfront.net/6a8895ff5f14ed0a38e4a6424448ab7730464c50/1ccd8/static/1db77a76a9b6781e795b113b665af148/469fe/network.jpg" alt="" style="position:absolute;top:0;left:0;opacity:1;width:100%;height:100%;object-fit:cover;object-position:center"/></picture></noscript></div><h1>Build an HTTPS-intercepting JavaScript proxy in 30 seconds flat</h1><div><p>HTTP(S) is the glue that binds together modern architectures, passing requests between microservices and connecting web &#x26; mobile apps alike to the APIs they depend on.</p>
<p>What if you could embed scripts directly into that glue?</p>
<p>By doing so, you could:</p>
<ul>
<li>Inject errors, timeouts and unusual responses to test system reliability.</li>
<li>Record &#x26; report traffic from all clients for later analysis.</li>
<li>Redirect requests to replace production servers with local test servers.</li>
<li>Automatically validate and debug HTTP interactions across an entire system.</li>
</ul>
<p>It turns out setting this up is super quick &#x26; easy to do. Using easily available JS libraries and scripts, you can start injecting code into HTTP interactions in no time at all. Let's see how it works.</p>
<h2 id="putting-the-basics-together"><a href="#putting-the-basics-together" aria-label="putting the basics together permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Putting the basics together</h2>
<p><a href="https://www.npmjs.com/package/mockttp">Mockttp</a> is the open-source HTTP library that powers all the internals of <a href="https://httptoolkit.tech/">HTTP Toolkit</a>, built in TypeScript. It can act as an HTTP(S) server or proxy, to intercept and mock traffic, transform responses, inject errors, or fire events for all the traffic it receives.</p>
<p>First though, if you want to inspect &#x26; edit HTTP manually with a full UI and tools on top, it's better to <strong><a href="https://httptoolkit.tech">download HTTP Toolkit</a></strong> for free right now instead, and start there!</p>
<p>On the other hand, if you do want to build scripts and automations that capture &#x26; rewrite HTTPS, or if you've used HTTP Toolkit and now you want to create complex custom behaviour on top of its built-in rules, then Mockttp is perfect, and you're in the right place.</p>
<p>Getting started with Mockttp is easy: install it, define a server, and start it. That looks like this:</p>
<ul>
<li>
<p>Create a new directory</p>
</li>
<li>
<p>Run <code class="language-text">npm install mockttp</code></p>
</li>
<li>
<p>Create an <code class="language-text">index.js</code> script:</p>
<div class="gatsby-highlight" data-language="javascript">
      <pre class="language-javascript"><code class="language-javascript"><span class="token punctuation">(</span><span class="token keyword">async</span> <span class="token punctuation">(</span><span class="token punctuation">)</span> <span class="token operator">=></span> <span class="token punctuation">{</span>
    <span class="token keyword">const</span> mockttp <span class="token operator">=</span> <span class="token function">require</span><span class="token punctuation">(</span><span class="token string">'mockttp'</span><span class="token punctuation">)</span><span class="token punctuation">;</span>

    <span class="token comment">// Create a proxy server with a self-signed HTTPS CA certificate:</span>
    <span class="token keyword">const</span> https <span class="token operator">=</span> <span class="token keyword">await</span> mockttp<span class="token punctuation">.</span><span class="token function">generateCACertificate</span><span class="token punctuation">(</span><span class="token punctuation">)</span><span class="token punctuation">;</span>
    <span class="token keyword">const</span> server <span class="token operator">=</span> mockttp<span class="token punctuation">.</span><span class="token function">getLocal</span><span class="token punctuation">(</span><span class="token punctuation">{</span> https <span class="token punctuation">}</span><span class="token punctuation">)</span><span class="token punctuation">;</span>

    <span class="token comment">// Inject 'Hello world' responses for all requests</span>
    server<span class="token punctuation">.</span><span class="token function">anyRequest</span><span class="token punctuation">(</span><span class="token punctuation">)</span><span class="token punctuation">.</span><span class="token function">thenReply</span><span class="token punctuation">(</span><span class="token number">200</span><span class="token punctuation">,</span> <span class="token string">"Hello world"</span><span class="token punctuation">)</span><span class="token punctuation">;</span>
    <span class="token keyword">await</span> server<span class="token punctuation">.</span><span class="token function">start</span><span class="token punctuation">(</span><span class="token punctuation">)</span><span class="token punctuation">;</span>

    <span class="token comment">// Print out the server details:</span>
    <span class="token keyword">const</span> caFingerprint <span class="token operator">=</span> mockttp<span class="token punctuation">.</span><span class="token function">generateSPKIFingerprint</span><span class="token punctuation">(</span>https<span class="token punctuation">.</span>cert<span class="token punctuation">)</span>
    console<span class="token punctuation">.</span><span class="token function">log</span><span class="token punctuation">(</span><span class="token template-string"><span class="token string">`Server running on port </span><span class="token interpolation"><span class="token interpolation-punctuation punctuation">${</span>server<span class="token punctuation">.</span>port<span class="token interpolation-punctuation punctuation">}</span></span><span class="token string">`</span></span><span class="token punctuation">)</span><span class="token punctuation">;</span>
    console<span class="token punctuation">.</span><span class="token function">log</span><span class="token punctuation">(</span><span class="token template-string"><span class="token string">`CA cert fingerprint </span><span class="token interpolation"><span class="token interpolation-punctuation punctuation">${</span>caFingerprint<span class="token interpolation-punctuation punctuation">}</span></span><span class="token string">`</span></span><span class="token punctuation">)</span><span class="token punctuation">;</span>
<span class="token punctuation">}</span><span class="token punctuation">)</span><span class="token punctuation">(</span><span class="token punctuation">)</span><span class="token punctuation">;</span> <span class="token comment">// (Run in an async wrapper so we can use top-level await everywhere)</span></code></pre>
      </div>
</li>
<li>
<p>Start the proxy by running <code class="language-text">node index.js</code></p>
</li>
</ul>
<p>And you're done!</p>
<p>To make this even easier I've bundled up a ready-to-use repo for this, along with easy Chrome setup to test it, <a href="https://github.com/httptoolkit/mockttp-proxy-demo/">on GitHub</a>.</p>
<p>This creates an HTTPS-intercepting <a href="https://en.wikipedia.org/wiki/Man-in-the-middle_attack">MitM</a> proxy. All requests sent to this server directly or sent through this server as a proxy will receive an immediately 200 "Hello world" response.</p>
<p>From the client's point of view (once configured) it will appear that this fake response has come directly from the real target URL (e.g. <code class="language-text">https://google.com/</code>) even though it's clearly being injected by our script.</p>
<p>When started, this script prints the port it's running on, the fingerprint of CA certificate used, which you can use to quickly temporarily trust that certificate in some clients, e.g. all Chromium browsers.</p>
<p>To test your proxy right now, connect a browser to it (assuming you have Chrome installed) by running:</p>
<div class="gatsby-highlight" data-language="bash">
      <pre class="language-bash"><code class="language-bash">google-chrome --proxy-server<span class="token operator">=</span>localhost:<span class="token variable">$PORT</span> --ignore-certificate-errors-spki-list<span class="token operator">=</span><span class="token variable">$CERT_FINGERPRINT</span> --user-data-dir<span class="token operator">=</span><span class="token variable">$ANY_PATH</span></code></pre>
      </div>
<p>You'll need to replace the $variables appropriately ($ANY_PATH will be used to store the profile data for a new temporary Chrome profile that will trust this CA certificate) and you may need to find the full path to the browser binary on your machine, if it's not in your $PATH itself.</p>
<p>If you don't like Chrome, the exact same arguments will work for any other Chromium-based browser, e.g. Edge or Brave, and we'll look at how to intercept all sorts of other clients too in just a minute.</p>
<p>If you run this, and visit any URL in the browser that opens, you should immediately see your "Hello world" response being returned from all requests to any URL, complete with the nice padlock that confirms that this message definitely <em>definitely</em> came from the real website:</p>
<p><span
      class="gatsby-resp-image-wrapper"
      style="position: relative; display: block; margin-left: auto; margin-right: auto; max-width: 632px; "
    >
      <a
    class="gatsby-resp-image-link"
    href="/static/f0de21d47fd49cebc9f826699fe99066/f6c80/google-replaced-with-hello-world.png"
    style="display: block"
    target="_blank"
    rel="noopener"
  >
    <span
    class="gatsby-resp-image-background-image"
    style="padding-bottom: 45.88235294117647%; position: relative; bottom: 0; left: 0; background-image: url('data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABQAAAAJCAIAAAC9o5sfAAAACXBIWXMAAAsTAAALEwEAmpwYAAAAiElEQVQoz2PgNbXnN3fkNXXgN3PkM3PkMrZj1bfiNLJlM7Bh0bPEiph1LSAMBhZdCyZtM1ZdCzZDG04zJ05TRzZjeyYDG1yI1dCW39yJ28iWQd2YYeXWHau27QSirQeP7DhyfMfh49sPH9t26OhWHAgoBVGw5cBhhv8UAIZ/MPCXdECZzUNTMwCMUqRaLvj3xgAAAABJRU5ErkJggg=='); background-size: cover; display: block;"
  ></span>
  <img
        class="gatsby-resp-image-image"
        alt="Chrome, showing a HTTPS google URL sending a Hello World response"
        title="Chrome, showing a HTTPS google URL sending a Hello World response"
        src="https://d33wubrfki0l68.cloudfront.net/f5575466b7405abb559a92c48293dd8a32e288e5/d38d8/static/f0de21d47fd49cebc9f826699fe99066/f6c80/google-replaced-with-hello-world.png"
        srcset="https://d33wubrfki0l68.cloudfront.net/accd9607fe50e4e14b2ab37a11006c23e3e37814/581a1/static/f0de21d47fd49cebc9f826699fe99066/ed1ad/google-replaced-with-hello-world.png 255w,
https://d33wubrfki0l68.cloudfront.net/4e2423bc5cf81113252fa34e8469abf6d57ac806/21c90/static/f0de21d47fd49cebc9f826699fe99066/292f0/google-replaced-with-hello-world.png 512w,
https://d33wubrfki0l68.cloudfront.net/f5575466b7405abb559a92c48293dd8a32e288e5/d38d8/static/f0de21d47fd49cebc9f826699fe99066/f6c80/google-replaced-with-hello-world.png 632w"
        sizes="(max-width: 632px) 100vw, 632px"
        style="width:100%;height:100%;margin:0;vertical-align:middle;position:absolute;top:0;left:0;"
        loading="lazy"
      />
  </a>
    </span></p>
<p>Neat!</p>
<p>With this, we can now invisibly rewrite real HTTPS traffic. Let's make that traffic do something more exciting.</p>
<h2 id="rewriting-https-dynamically"><a href="#rewriting-https-dynamically" aria-label="rewriting https dynamically permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Rewriting HTTPS dynamically</h2>
<p>Mockttp lets you define rules, which match certain requests, and then perform certain actions.</p>
<p>Above, we've created a script that matches all requests, and always returns a fixed response. But there's a lot of other things we could do, for example:</p>
<div class="gatsby-highlight" data-language="javascript">
      <pre class="language-javascript"><code class="language-javascript"><span class="token comment">// Proxy all example.com traffic through as normal, untouched:</span>
server<span class="token punctuation">.</span><span class="token function">anyRequest</span><span class="token punctuation">(</span><span class="token punctuation">)</span>
    <span class="token punctuation">.</span><span class="token function">forHost</span><span class="token punctuation">(</span><span class="token string">"example.com"</span><span class="token punctuation">)</span>
    <span class="token punctuation">.</span><span class="token function">thenPassThrough</span><span class="token punctuation">(</span><span class="token punctuation">)</span><span class="token punctuation">;</span>

<span class="token comment">// Make all GET requests to google.com time out:</span>
server<span class="token punctuation">.</span><span class="token function">get</span><span class="token punctuation">(</span><span class="token string">"google.com"</span><span class="token punctuation">)</span><span class="token punctuation">.</span><span class="token function">thenTimeout</span><span class="token punctuation">(</span><span class="token punctuation">)</span><span class="token punctuation">;</span>

<span class="token comment">// Redirect any github requests to wikipedia.org:</span>
server<span class="token punctuation">.</span><span class="token function">anyRequest</span><span class="token punctuation">(</span><span class="token punctuation">)</span>
    <span class="token punctuation">.</span><span class="token function">forHost</span><span class="token punctuation">(</span><span class="token string">"github.com"</span><span class="token punctuation">)</span>
    <span class="token punctuation">.</span><span class="token function">thenForwardTo</span><span class="token punctuation">(</span><span class="token string">"https://www.wikipedia.org"</span><span class="token punctuation">)</span><span class="token punctuation">;</span>

<span class="token comment">// Intercept /api?userId=123 on any host, serve the response from a file:</span>
server<span class="token punctuation">.</span><span class="token function">get</span><span class="token punctuation">(</span><span class="token string">"/api"</span><span class="token punctuation">)</span>
    <span class="token punctuation">.</span><span class="token function">withQuery</span><span class="token punctuation">(</span><span class="token punctuation">{</span> userId<span class="token punctuation">:</span> <span class="token number">123</span> <span class="token punctuation">}</span><span class="token punctuation">)</span>
    <span class="token punctuation">.</span><span class="token function">thenFromFile</span><span class="token punctuation">(</span><span class="token number">200</span><span class="token punctuation">,</span> <span class="token string">"/path/to/a/file"</span><span class="token punctuation">)</span><span class="token punctuation">;</span>

<span class="token comment">// Forcibly close any connection if a POST request is sent:</span>
server<span class="token punctuation">.</span><span class="token function">post</span><span class="token punctuation">(</span><span class="token punctuation">)</span><span class="token punctuation">.</span><span class="token function">thenCloseConnection</span><span class="token punctuation">(</span><span class="token punctuation">)</span><span class="token punctuation">;</span></code></pre>
      </div>
<p>Rules like these give you the power to rewrite traffic any way you like: pass it through untouched like normal, replace responses, redirect traffic, you name it.</p>
<p>Replace the "hello world" line in the previous example with some of these rules, restart your server, and then try browsing the web again. Example.com will now work fine, but Google will be completely inaccessible, all POST requests will fail, and Github.com will be inexplicably replaced with the content of Wikipedia.org:</p>
<p><span
      class="gatsby-resp-image-wrapper"
      style="position: relative; display: block; margin-left: auto; margin-right: auto; max-width: 685px; "
    >
      <a
    class="gatsby-resp-image-link"
    href="/static/00109728493803e0e3a2bfc7385612b8/691c5/github-as-wikipedia.png"
    style="display: block"
    target="_blank"
    rel="noopener"
  >
    <span
    class="gatsby-resp-image-background-image"
    style="padding-bottom: 87.74703557312253%; position: relative; bottom: 0; left: 0; background-image: url('data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABQAAAASCAIAAADUsmlHAAAACXBIWXMAAAsTAAALEwEAmpwYAAACRUlEQVQ4y31SW2sTQRQOhaKkIvoi/gHfLMUqJJimD1ZrX/Wn+O7P8EcYFKqk2CKKaBXtQ6AkaTFXc2k2t83szM7sZW7x7K4kMYkevh0Os+c75ztnTuzW3tOb23vxe9uX7qRW1hMr68nVjfurG+An/4fbAWLxu+nLm1vxzfTV5MPrW4+vpXbXkjvxxAPAWmInwqwPuAKRqUc30ruxfKkCKJQqxXK1WKkBCqHz81fjrFo/r9XhjC5nUQwRGy8zIQTBllZKaz2GT6ulYTH9tykVxHmel8vl8oVCPjTDMOBSL9h85bDSOOLbtk0pRcgCIdGv+cpTWniYyKm0CGXebDTnotmjDYPyMMsSMpjtSIs4kUkZ6JdSMsaA4ziuTR1su0otIyslaxek3bPHWgGnUqmClUrlw6P3p6f5IDXzG4YN2f+onCUzl/dNG2EKM7MwzmYP9vff1Gr1z1++vsy8huZ9nw9G1LQYPMI8GWHnok+xHXTb7faazdZwaHY6xvHxNyCbpimV7gzs7pDBCObJgvMhckJVY0JICdameFat1jKZV2+zB1H/I+zCK0i5QPZ8Xm8jhFnUkmF0v/84+fDx07vDIwtZYXa/3cUji2itFwcG+yQJ5X3kM1fCjeO6loWjtcFUjAiHUXIul5BDvu4OSdNAgxGejDQQLHinh+DXWP3jnbnQnq+E1CCAC+Vz7XEF8OEUWkrtC3VyTgp1OtmfKRmEmYRbVCA7ADizGCDW6rEnzwvPXpQjjXM9aygbgcupPwsTc8zkhPIbE+Wkh4+uiN4AAAAASUVORK5CYII='); background-size: cover; display: block;"
  ></span>
  <img
        class="gatsby-resp-image-image"
        alt="GitHub.com in the URL bar, Wikipedia on the page"
        title="GitHub.com in the URL bar, Wikipedia on the page"
        src="https://d33wubrfki0l68.cloudfront.net/b92ff3d83a8b1f7ee950d1ba08ce7a469ed41a61/f7d23/static/00109728493803e0e3a2bfc7385612b8/691c5/github-as-wikipedia.png"
        srcset="https://d33wubrfki0l68.cloudfront.net/d3a1e4ada9f4284160875d58df8d9cc83a588751/d209e/static/00109728493803e0e3a2bfc7385612b8/ffbd3/github-as-wikipedia.png 253w,
https://d33wubrfki0l68.cloudfront.net/d456443ee6e9325ca8ae233b776049c9150600aa/29451/static/00109728493803e0e3a2bfc7385612b8/18c61/github-as-wikipedia.png 506w,
https://d33wubrfki0l68.cloudfront.net/b92ff3d83a8b1f7ee950d1ba08ce7a469ed41a61/f7d23/static/00109728493803e0e3a2bfc7385612b8/691c5/github-as-wikipedia.png 685w"
        sizes="(max-width: 685px) 100vw, 685px"
        style="width:100%;height:100%;margin:0;vertical-align:middle;position:absolute;top:0;left:0;"
        loading="lazy"
      />
  </a>
    </span></p>
<p>If you'd like to use more rules like this, the <a href="https://httptoolkit.github.io/mockttp/interfaces/_mockttp_.mockttp.html">detailed API docs</a> provide more specific information on each of the methods available and how they work.</p>
<p>By default each rule will only be run for the first matching request it sees, until all matching rules have been run, in which case the last matching rule will repeat indefinitely. You can control this more precisely by adding <code class="language-text">.always()</code>, <code class="language-text">.once()</code>, <code class="language-text">.times(n)</code>, etc, as part of the rule definition. If you're defining overlapping rules, you probably want to use <code class="language-text">.always()</code> every time.</p>
<h2 id="advanced-custom-rewrite-logic"><a href="#advanced-custom-rewrite-logic" aria-label="advanced custom rewrite logic permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Advanced custom rewrite logic</h2>
<p>There's some more advanced types of rule we can add to our script: we can define our own custom request or response transformation logic.</p>
<p>Using this, it's possible to run arbitrary code that can send a response directly, intercept a request as it's sent upstream, or intercept a response that's received from a real server. You can examine all real request &#x26; response content in your code, and then complete that request or response with your own changes included.</p>
<p>That looks like this:</p>
<div class="gatsby-highlight" data-language="javascript">
      <pre class="language-javascript"><code class="language-javascript"><span class="token comment">// Replace targets entirely with custom logic:</span>
<span class="token keyword">let</span> counter <span class="token operator">=</span> <span class="token number">0</span><span class="token punctuation">;</span>
server<span class="token punctuation">.</span><span class="token function">anyRequest</span><span class="token punctuation">(</span><span class="token punctuation">)</span><span class="token punctuation">.</span><span class="token function">forHost</span><span class="token punctuation">(</span><span class="token string">"google.com"</span><span class="token punctuation">)</span><span class="token punctuation">.</span><span class="token function">thenCallback</span><span class="token punctuation">(</span><span class="token punctuation">(</span><span class="token parameter">request</span><span class="token punctuation">)</span> <span class="token operator">=></span> <span class="token punctuation">{</span>
    <span class="token comment">// This code will run for all requests to Google.com</span>
    <span class="token keyword">return</span> <span class="token punctuation">{</span>
        status<span class="token punctuation">:</span> <span class="token number">200</span><span class="token punctuation">,</span>
        <span class="token comment">// Return a JSON response with an incrementing counter:</span>
        json<span class="token punctuation">:</span> <span class="token punctuation">{</span> counterValue<span class="token punctuation">:</span> counter<span class="token operator">++</span> <span class="token punctuation">}</span>
    <span class="token punctuation">}</span><span class="token punctuation">;</span>
<span class="token punctuation">}</span><span class="token punctuation">)</span><span class="token punctuation">;</span>

<span class="token comment">// Or wrap targets, transforming real requests &amp; responses:</span>
server<span class="token punctuation">.</span><span class="token function">anyRequest</span><span class="token punctuation">(</span><span class="token punctuation">)</span><span class="token punctuation">.</span><span class="token function">forHost</span><span class="token punctuation">(</span><span class="token string">"example.com"</span><span class="token punctuation">)</span><span class="token punctuation">.</span><span class="token function">thenPassThrough</span><span class="token punctuation">(</span><span class="token punctuation">{</span>
    <span class="token function-variable function">beforeResponse</span><span class="token punctuation">:</span> <span class="token punctuation">(</span><span class="token parameter">response</span><span class="token punctuation">)</span> <span class="token operator">=></span> <span class="token punctuation">{</span>
        <span class="token comment">// Here you can access the real response:</span>
        console<span class="token punctuation">.</span><span class="token function">log</span><span class="token punctuation">(</span><span class="token template-string"><span class="token string">`Got </span><span class="token interpolation"><span class="token interpolation-punctuation punctuation">${</span>response<span class="token punctuation">.</span>statusCode<span class="token interpolation-punctuation punctuation">}</span></span><span class="token string"> response with body: </span><span class="token interpolation"><span class="token interpolation-punctuation punctuation">${</span>response<span class="token punctuation">.</span>body<span class="token punctuation">.</span>text<span class="token interpolation-punctuation punctuation">}</span></span><span class="token string">`</span></span><span class="token punctuation">)</span><span class="token punctuation">;</span>

        <span class="token comment">// Values returned here replace parts of the response:</span>
        <span class="token keyword">if</span> <span class="token punctuation">(</span>response<span class="token punctuation">.</span>headers<span class="token punctuation">[</span><span class="token string">'content-type'</span><span class="token punctuation">]</span><span class="token operator">?</span><span class="token punctuation">.</span><span class="token function">startsWith</span><span class="token punctuation">(</span><span class="token string">'text/html'</span><span class="token punctuation">)</span><span class="token punctuation">)</span> <span class="token punctuation">{</span>
            <span class="token comment">// E.g. append to all HTML response bodies:</span>
            <span class="token keyword">return</span> <span class="token punctuation">{</span>
                headers<span class="token punctuation">:</span> <span class="token punctuation">{</span> <span class="token string">'content-type'</span><span class="token punctuation">:</span> <span class="token string">'text/html'</span> <span class="token punctuation">}</span><span class="token punctuation">,</span>
                body<span class="token punctuation">:</span> response<span class="token punctuation">.</span>body<span class="token punctuation">.</span>text <span class="token operator">+</span> <span class="token string">" appended"</span>
            <span class="token punctuation">}</span><span class="token punctuation">;</span>
        <span class="token punctuation">}</span> <span class="token keyword">else</span> <span class="token punctuation">{</span>
            <span class="token keyword">return</span> <span class="token punctuation">{</span><span class="token punctuation">}</span><span class="token punctuation">;</span>
        <span class="token punctuation">}</span>
    <span class="token punctuation">}</span>
<span class="token punctuation">}</span><span class="token punctuation">)</span><span class="token punctuation">;</span></code></pre>
      </div>
<p>The first rule will handle all Google.com requests by itself. The second rule will forward requests upstream, get a response, and then run the custom logic before returning the appended response back to the client:</p>
<p><span
      class="gatsby-resp-image-wrapper"
      style="position: relative; display: block; margin-left: auto; margin-right: auto; max-width: 720px; "
    >
      <a
    class="gatsby-resp-image-link"
    href="/static/947fcb061b4d4bdcf79d6b9713fbfcf0/2732c/example.com-with-text-appended.png"
    style="display: block"
    target="_blank"
    rel="noopener"
  >
    <span
    class="gatsby-resp-image-background-image"
    style="padding-bottom: 72.265625%; position: relative; bottom: 0; left: 0; background-image: url('data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABMAAAAOCAIAAABCerDeAAAACXBIWXMAAAsSAAALEgHS3X78AAABcUlEQVQoz5WQ7UvCUBTGbxHR96iEEvqqRAUZRUaQlRAY2d8sfdCUkEBC50ydm5luc/fu5eo2e3RS9GLk5cfdc+89Z885hyzvnazsB8SXdo9JNLa4c7QQPSSRg5lEYyQSI6vx5NppMnR2vXl5G07ebV2lQxc36+epWWwkUtvJdDiRImK9GVBrSFPqkvgnk4AmMU3LZBajJqWMGoxRYLKpxpv1kyCFGAbzPH/028I95+5g8J3h0LMsh1iWraqaKL7UavVqtYY90JVKtdVSkO+6vueNPvAnLpwPkOkoymuh8JjLPWQy98XiE8jnC9lsrlyuIMj3PyuCDJIdZ4A+bUrNRkOS5Xan05XwlduyrDSbLUlqIRnmKEEQRDCJedN1yvlw7NnraaXSc7ksQHS7KnaAFlRV17Q+dL9PAYRt86D4sSdj6NTVdK4bvKfaDvdGs9eXajFbzGouYAtzElQyL7puEDQG0A8Oc0EwGEGoYqrBn/7PO0sHlj6AiT1MAAAAAElFTkSuQmCC'); background-size: cover; display: block;"
  ></span>
  <img
        class="gatsby-resp-image-image"
        alt="Example.com with extra text appended"
        title="Example.com with extra text appended"
        src="https://d33wubrfki0l68.cloudfront.net/6c0c9cf97e8c696eecb94fc5e1ab3401b2908228/f1b12/static/947fcb061b4d4bdcf79d6b9713fbfcf0/2732c/example.com-with-text-appended.png"
        srcset="https://d33wubrfki0l68.cloudfront.net/3ee55024ae233fedb02fd9d83dd5c07038916826/eceb2/static/947fcb061b4d4bdcf79d6b9713fbfcf0/1ea52/example.com-with-text-appended.png 256w,
https://d33wubrfki0l68.cloudfront.net/bd4203cdc0db3d26ccd4f1a00561721fe8076396/bca86/static/947fcb061b4d4bdcf79d6b9713fbfcf0/083d3/example.com-with-text-appended.png 512w,
https://d33wubrfki0l68.cloudfront.net/6c0c9cf97e8c696eecb94fc5e1ab3401b2908228/f1b12/static/947fcb061b4d4bdcf79d6b9713fbfcf0/2732c/example.com-with-text-appended.png 720w"
        sizes="(max-width: 720px) 100vw, 720px"
        style="width:100%;height:100%;margin:0;vertical-align:middle;position:absolute;top:0;left:0;"
        loading="lazy"
      />
  </a>
    </span></p>
<p>You can similarly use <code class="language-text">beforeRequest</code> to change the content of outgoing requests. Check <a href="https://httptoolkit.github.io/mockttp/interfaces/_rules_requests_request_handlers_.passthroughhandleroptions.html#beforerequest">the docs</a> for a full list of the options and return values available.</p>
<h2 id="connecting-more-clients"><a href="#connecting-more-clients" aria-label="connecting more clients permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Connecting more clients</h2>
<p>So far we've created a proxy that can automatically rewrite specific traffic from a Chromium-based browser. That's great, but a bit limited. How do you connect more clients?</p>
<p>There are generally two steps required:</p>
<ol>
<li>Configure the client to use your Mockttp proxy as its HTTP(S) proxy</li>
<li>Configure the client to trust your HTTPS CA certificate</li>
</ol>
<h3 id="configuring-your-client-to-use-your-proxy"><a href="#configuring-your-client-to-use-your-proxy" aria-label="configuring your client to use your proxy permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Configuring your client to use your proxy</h3>
<p>Configuring the proxy settings will depend on the specific HTTP client you're using, but is normally fairly simple and well documented.</p>
<p>You can often get away with just setting <code class="language-text">HTTP_PROXY</code> and <code class="language-text">HTTPS_PROXY</code> environment variables to <code class="language-text">http://127.0.0.1:$YOUR_PROXY_PORT</code>, as that's a common convention, but that won't work everywhere. Alternatively, in many cases you can change your system-wide proxy settings to use this proxy, but be aware that this will intercept <em>all</em> traffic on your machine, not just the target application.</p>
<p>If you want to intercept a Node.js application specifically, there is no global configuration option, but you can use the <a href="https://www.npmjs.com/package/global-agent">global-agent</a> npm module with a <code class="language-text">GLOBAL_AGENT_HTTP_PROXY</code> environment variable to do this like so:</p>
<div class="gatsby-highlight" data-language="bash">
      <pre class="language-bash"><code class="language-bash"><span class="token function">npm</span> <span class="token function">install</span> global-agent

<span class="token function">export</span> GLOBAL_AGENT_HTTP_PROXY<span class="token operator">=</span>http://127.0.0.1:<span class="token variable">$YOUR_PROXY_PORT</span>
node -r <span class="token string">'global-agent/bootstrap'</span> your-target-app.js</code></pre>
      </div>
<p>For other cases, you'll need to look into the docs for the HTTP client in question.</p>
<h3 id="configuring-your-client-to-trust-your-ca-certificate"><a href="#configuring-your-client-to-trust-your-ca-certificate" aria-label="configuring your client to trust your ca certificate permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Configuring your client to trust your CA certificate</h3>
<p>This is the step that ensures the client trusts your proxy to rewrite HTTPS.</p>
<p>It's normally easiest to create CA certificate files on disk, and then import them, so you can easily load them directly into other software.</p>
<p>You can do that in JS by saving the <code class="language-text">key</code> and <code class="language-text">cert</code> properties of the CA certificate to a file. Like so:</p>
<div class="gatsby-highlight" data-language="javascript">
      <pre class="language-javascript"><code class="language-javascript"><span class="token keyword">const</span> mockttp <span class="token operator">=</span> <span class="token function">require</span><span class="token punctuation">(</span><span class="token string">'mockttp'</span><span class="token punctuation">)</span><span class="token punctuation">;</span>
<span class="token keyword">const</span> fs <span class="token operator">=</span> <span class="token function">require</span><span class="token punctuation">(</span><span class="token string">'fs'</span><span class="token punctuation">)</span><span class="token punctuation">;</span>
<span class="token keyword">const</span> <span class="token punctuation">{</span> key<span class="token punctuation">,</span> cert <span class="token punctuation">}</span> <span class="token operator">=</span> <span class="token keyword">await</span> mockttp<span class="token punctuation">.</span><span class="token function">generateCACertificate</span><span class="token punctuation">(</span><span class="token punctuation">)</span><span class="token punctuation">;</span>
fs<span class="token punctuation">.</span><span class="token function">writeFile</span><span class="token punctuation">(</span><span class="token string">"key.pem"</span><span class="token punctuation">,</span> key<span class="token punctuation">)</span><span class="token punctuation">;</span>
fs<span class="token punctuation">.</span><span class="token function">writeFile</span><span class="token punctuation">(</span><span class="token string">"cert.pem"</span><span class="token punctuation">,</span> cert<span class="token punctuation">)</span><span class="token punctuation">;</span></code></pre>
      </div>
<p>This creates <code class="language-text">key.pem</code> (your certificate private key) and <code class="language-text">cert.pem</code> (your public CA certificate) files on disk, so you can use the same key &#x26; certificate every time, and so you can import the CA certificate into your HTTPS clients.</p>
<p>You can reuse these saved certificate details, instead of creating a certificate from scratch every time, by changing your server setup to look like this:</p>
<div class="gatsby-highlight" data-language="javascript">
      <pre class="language-javascript"><code class="language-javascript"><span class="token keyword">const</span> server <span class="token operator">=</span> mockttp<span class="token punctuation">.</span><span class="token function">getLocal</span><span class="token punctuation">(</span><span class="token punctuation">{</span>
    https<span class="token punctuation">:</span> <span class="token punctuation">{</span>
        keyPath<span class="token punctuation">:</span> <span class="token string">'./key.pem'</span><span class="token punctuation">,</span>
        certPath<span class="token punctuation">:</span> <span class="token string">'./cert.pem'</span>
    <span class="token punctuation">}</span>
<span class="token punctuation">}</span><span class="token punctuation">)</span><span class="token punctuation">;</span></code></pre>
      </div>
<p>These certificate files can be imported into most tools either via UIs (e.g. in Firefox's certificate settings) or via environment variables (e.g. <code class="language-text">SSL_CERT_FILE=/path/to/cert.pem</code>).</p>
<p>If you want to intercept a Node.js process, there's a custom <code class="language-text">NODE_EXTRA_CA_CERTS</code> variable you can use to do this.</p>
<p>As a full example, combining that with the proxy settings above, that looks like this:</p>
<div class="gatsby-highlight" data-language="bash">
      <pre class="language-bash"><code class="language-bash"><span class="token function">export</span> NODE_EXTRA_CA_CERTS<span class="token operator">=</span>/path/to/cert.pem <span class="token comment"># Trust the cert</span>
<span class="token function">export</span> GLOBAL_AGENT_HTTP_PROXY<span class="token operator">=</span>http://127.0.0.1:<span class="token variable">$YOUR_PROXY_PORT</span> <span class="token comment"># Use the proxy</span>

<span class="token comment"># Start your target app, fully intercepted:</span>
node -r <span class="token string">'global-agent/bootstrap'</span> your-target-app.js</code></pre>
      </div>
<p>If you're having trouble with either of these steps, you may be interested in <a href="https://github.com/httptoolkit/httptoolkit-server/tree/master/src/interceptors">the source behind the HTTP Toolkit Server</a>, which automatically sets up a wide variety of clients for use with HTTP Toolkit in general, from Android to Electron apps to JVM processes.</p>
<h2 id="going-further"><a href="#going-further" aria-label="going further permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Going further</h2>
<p>To wrap up then, what can you do with this? Here are some ideas:</p>
<ul>
<li>Create a proxy that completely blocks various hostnames or file types. No more ad networks, no more PDFs, no JS bigger than 100KB, whatever you like.</li>
<li>Proxy traffic during testing to replace some of your internal services or external dependencies with simple mocked versions, with no code changes required in the system under test.</li>
<li>Capture and log all traffic sent through your proxy matching certain patterns.</li>
<li>Randomly add delays or timeouts to test the reliability of your clients in unstable environments.</li>
<li>Combine this with <strong><a href="https://httptoolkit.tech">HTTP Toolkit</a></strong> by redirecting some traffic there to your local proxy, to combine a full debugging UI with any custom logic you please, like so:
<span
      class="gatsby-resp-image-wrapper"
      style="position: relative; display: block; margin-left: auto; margin-right: auto; max-width: 911px; "
    >
      <a
    class="gatsby-resp-image-link"
    href="/static/1ee49590135cafd240227cabf3113209/32a13/http-toolkit-to-mockttp-rule.png"
    style="display: block"
    target="_blank"
    rel="noopener"
  >
    <span
    class="gatsby-resp-image-background-image"
    style="padding-bottom: 36.32812499999999%; position: relative; bottom: 0; left: 0; background-image: url('data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABMAAAAHCAIAAABldeEWAAAACXBIWXMAAAsSAAALEgHS3X78AAABF0lEQVQY02WQ2W6DMBBF/Z/9t35LX/vQJhKxIahsDlsg3pcAMVGnVKgPPbLs8ZV1x3dQVbfa2BvnXEomFBMSCmWstg6W1GbTBehXrtqR4cuYNCxtGcqKUgqxzPM8/QHX5/pYQ+CCO+fCAwBtmebJ+tlPs3F3dCLx6QRbXNd1v9N23eFcaufLsjwej4QQjEmapnAmMSnybBgG9JUXZVFch8FuaG2ctaOQL6/vH1lvBKP0QikVQnjv4YExxjtnnUMkOWOMoW0URUmS1E0DzStK3z4joc1tHLMsBwXmwBjTYGyMVspah5quDyH8xoOwy054LKBXVQWOYL19GOd53nUdxJFKobbvn+u6/AM8YCzqx97ed/zGVty/AUVUbxg3Bw1cAAAAAElFTkSuQmCC'); background-size: cover; display: block;"
  ></span>
  <img
        class="gatsby-resp-image-image"
        alt="An HTTP Toolkit rule forwarding traffic to a local proxy"
        title="An HTTP Toolkit rule forwarding traffic to a local proxy"
        src="https://d33wubrfki0l68.cloudfront.net/420133bd953dd2a3ce1941b7df51f829b48b1182/202db/static/1ee49590135cafd240227cabf3113209/32a13/http-toolkit-to-mockttp-rule.png"
        srcset="https://d33wubrfki0l68.cloudfront.net/0dabfe258f9f954eac2d6108e0221bf106167e53/4b755/static/1ee49590135cafd240227cabf3113209/0a250/http-toolkit-to-mockttp-rule.png 256w,
https://d33wubrfki0l68.cloudfront.net/5a116de9c8043fea193772ddf5c07134b551deb5/d77aa/static/1ee49590135cafd240227cabf3113209/a7a89/http-toolkit-to-mockttp-rule.png 512w,
https://d33wubrfki0l68.cloudfront.net/420133bd953dd2a3ce1941b7df51f829b48b1182/202db/static/1ee49590135cafd240227cabf3113209/32a13/http-toolkit-to-mockttp-rule.png 911w"
        sizes="(max-width: 911px) 100vw, 911px"
        style="width:100%;height:100%;margin:0;vertical-align:middle;position:absolute;top:0;left:0;"
        loading="lazy"
      />
  </a>
    </span></li>
</ul>
<p>Play around with <a href="https://github.com/httptoolkit/mockttp-proxy-demo/">the example repo</a>, and feel free to get in touch <a href="https://twitter.com/pimterry">on Twitter</a> if you build anything cool or if you have any questions.</p></div><p title="Apr 27th 2021" class="sc-jtRlXQ dpxSoa"><span>Published <!-- -->a day ago<!-- --> by <a href="https://twitter.com/pimterry">Tim Perry</a></span><img src="data:image/png;base64,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" alt="Picture of Tim Perry" class="sc-htoDjs cWnjEm"/></p></article><div class="sc-ePZHVD dYwfEO"><a class="sc-likbZx ccYauZ" title="Share this post on Twitter" href="https://twitter.com//intent/tweet?text=Build an HTTPS-intercepting JavaScript proxy in 30 seconds flat&amp;url=https://httptoolkit.tech/blog/javascript-mitm-proxy-mockttp/" target="_blank" rel="noopener noreferrer"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="twitter" class="svg-inline--fa fa-twitter fa-w-16 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path fill="currentColor" d="M459.37 151.716c.325 4.548.325 9.097.325 13.645 0 138.72-105.583 298.558-298.558 298.558-59.452 0-114.68-17.219-161.137-47.106 8.447.974 16.568 1.299 25.34 1.299 49.055 0 94.213-16.568 130.274-44.832-46.132-.975-84.792-31.188-98.112-72.772 6.498.974 12.995 1.624 19.818 1.624 9.421 0 18.843-1.3 27.614-3.573-48.081-9.747-84.143-51.98-84.143-102.985v-1.299c13.969 7.797 30.214 12.67 47.431 13.319-28.264-18.843-46.781-51.005-46.781-87.391 0-19.492 5.197-37.36 14.294-52.954 51.655 63.675 129.3 105.258 216.365 109.807-1.624-7.797-2.599-15.918-2.599-24.04 0-57.828 46.782-104.934 104.934-104.934 30.213 0 57.502 12.67 76.67 33.137 23.715-4.548 46.456-13.32 66.599-25.34-7.798 24.366-24.366 44.833-46.132 57.827 21.117-2.273 41.584-8.122 60.426-16.243-14.292 20.791-32.161 39.308-52.628 54.253z"></path></svg></a><a class="sc-eKZiaR dKPMHb" title="Share this post on Reddit" href="http://www.reddit.com//submit?url=https://httptoolkit.tech/blog/javascript-mitm-proxy-mockttp/" target="_blank" rel="noopener noreferrer"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="reddit-alien" class="svg-inline--fa fa-reddit-alien fa-w-16 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path fill="currentColor" d="M440.3 203.5c-15 0-28.2 6.2-37.9 15.9-35.7-24.7-83.8-40.6-137.1-42.3L293 52.3l88.2 19.8c0 21.6 17.6 39.2 39.2 39.2 22 0 39.7-18.1 39.7-39.7s-17.6-39.7-39.7-39.7c-15.4 0-28.7 9.3-35.3 22l-97.4-21.6c-4.9-1.3-9.7 2.2-11 7.1L246.3 177c-52.9 2.2-100.5 18.1-136.3 42.8-9.7-10.1-23.4-16.3-38.4-16.3-55.6 0-73.8 74.6-22.9 100.1-1.8 7.9-2.6 16.3-2.6 24.7 0 83.8 94.4 151.7 210.3 151.7 116.4 0 210.8-67.9 210.8-151.7 0-8.4-.9-17.2-3.1-25.1 49.9-25.6 31.5-99.7-23.8-99.7zM129.4 308.9c0-22 17.6-39.7 39.7-39.7 21.6 0 39.2 17.6 39.2 39.7 0 21.6-17.6 39.2-39.2 39.2-22 .1-39.7-17.6-39.7-39.2zm214.3 93.5c-36.4 36.4-139.1 36.4-175.5 0-4-3.5-4-9.7 0-13.7 3.5-3.5 9.7-3.5 13.2 0 27.8 28.5 120 29 149 0 3.5-3.5 9.7-3.5 13.2 0 4.1 4 4.1 10.2.1 13.7zm-.8-54.2c-21.6 0-39.2-17.6-39.2-39.2 0-22 17.6-39.7 39.2-39.7 22 0 39.7 17.6 39.7 39.7-.1 21.5-17.7 39.2-39.7 39.2z"></path></svg></a><a class="sc-fgfRvd ctVXnp" title="Share this post on Hacker News" href="https://news.ycombinator.com/submitlink?u=https://httptoolkit.tech/blog/javascript-mitm-proxy-mockttp/" target="_blank" rel="noopener noreferrer"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="hacker-news" class="svg-inline--fa fa-hacker-news fa-w-14 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M0 32v448h448V32H0zm21.2 197.2H21c.1-.1.2-.3.3-.4 0 .1 0 .3-.1.4zm218 53.9V384h-31.4V281.3L128 128h37.3c52.5 98.3 49.2 101.2 59.3 125.6 12.3-27 5.8-24.4 60.6-125.6H320l-80.8 155.1z"></path></svg></a></div><div class="sc-dfVpRl jCTJvb"><div class="sc-gxMtzJ dxCDWd"><strong>Become an HTTP &amp; debugging expert</strong> by subscribing to receive <!-- -->more posts like this<!-- --> emailed straight to your inbox:<form action="https://tech.us18.list-manage.com/subscribe/post?u=f6e81ee3f567741ec9800aa56&amp;id=001b24c3da&amp;SOURCE=blog:subscribe" method="post" target="_blank" novalidate="" class="sc-iAyFgw bSmbcb"><input type="email" name="EMAIL" placeholder="Enter your email" title="Enter your email to stay up to date with new blog posts &amp; updates" value="" class="sc-dnqmqq cuYzWk"/><div style="position:absolute;left:-5000px"><input type="text" name="b_f6e81ee3f567741ec9800aa56_001b24c3da" tabindex="-1" aria-hidden="true" value=""/></div><input type="submit" value="Subscribe" name="subscribe" class="sc-gZMcBi lmdzyt"/><p class="sc-kkGfuU jmtVcB">No spam, just new blog posts hot off the press</p></form></div></div></section><div class="sc-bxivhb hOucDX"><div class="sc-ifAKCX jPtpSf"><a href="https://github.com/httptoolkit"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="github" class="svg-inline--fa fa-github fa-w-16 fa-2x " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 496 512"><path fill="currentColor" d="M165.9 397.4c0 2-2.3 3.6-5.2 3.6-3.3.3-5.6-1.3-5.6-3.6 0-2 2.3-3.6 5.2-3.6 3-.3 5.6 1.3 5.6 3.6zm-31.1-4.5c-.7 2 1.3 4.3 4.3 4.9 2.6 1 5.6 0 6.2-2s-1.3-4.3-4.3-5.2c-2.6-.7-5.5.3-6.2 2.3zm44.2-1.7c-2.9.7-4.9 2.6-4.6 4.9.3 2 2.9 3.3 5.9 2.6 2.9-.7 4.9-2.6 4.6-4.6-.3-1.9-3-3.2-5.9-2.9zM244.8 8C106.1 8 0 113.3 0 252c0 110.9 69.8 205.8 169.5 239.2 12.8 2.3 17.3-5.6 17.3-12.1 0-6.2-.3-40.4-.3-61.4 0 0-70 15-84.7-29.8 0 0-11.4-29.1-27.8-36.6 0 0-22.9-15.7 1.6-15.4 0 0 24.9 2 38.6 25.8 21.9 38.6 58.6 27.5 72.9 20.9 2.3-16 8.8-27.1 16-33.7-55.9-6.2-112.3-14.3-112.3-110.5 0-27.5 7.6-41.3 23.6-58.9-2.6-6.5-11.1-33.3 2.6-67.9 20.9-6.5 69 27 69 27 20-5.6 41.5-8.5 62.8-8.5s42.8 2.9 62.8 8.5c0 0 48.1-33.6 69-27 13.7 34.7 5.2 61.4 2.6 67.9 16 17.7 25.8 31.5 25.8 58.9 0 96.5-58.9 104.2-114.8 110.5 9.2 7.9 17 22.9 17 46.4 0 33.7-.3 75.4-.3 83.6 0 6.5 4.6 14.4 17.3 12.1C428.2 457.8 496 362.9 496 252 496 113.3 383.5 8 244.8 8zM97.2 352.9c-1.3 1-1 3.3.7 5.2 1.6 1.6 3.9 2.3 5.2 1 1.3-1 1-3.3-.7-5.2-1.6-1.6-3.9-2.3-5.2-1zm-10.8-8.1c-.7 1.3.3 2.9 2.3 3.9 1.6 1 3.6.7 4.3-.7.7-1.3-.3-2.9-2.3-3.9-2-.6-3.6-.3-4.3.7zm32.4 35.6c-1.6 1.3-1 4.3 1.3 6.2 2.3 2.3 5.2 2.6 6.5 1 1.3-1.3.7-4.3-1.3-6.2-2.2-2.3-5.2-2.6-6.5-1zm-11.4-14.7c-1.6 1-1.6 3.6 0 5.9 1.6 2.3 4.3 3.3 5.6 2.3 1.6-1.3 1.6-3.9 0-6.2-1.4-2.3-4-3.3-5.6-2z"></path></svg></a><a href="https://twitter.com/httptoolkit"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="twitter" class="svg-inline--fa fa-twitter fa-w-16 fa-2x " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path fill="currentColor" d="M459.37 151.716c.325 4.548.325 9.097.325 13.645 0 138.72-105.583 298.558-298.558 298.558-59.452 0-114.68-17.219-161.137-47.106 8.447.974 16.568 1.299 25.34 1.299 49.055 0 94.213-16.568 130.274-44.832-46.132-.975-84.792-31.188-98.112-72.772 6.498.974 12.995 1.624 19.818 1.624 9.421 0 18.843-1.3 27.614-3.573-48.081-9.747-84.143-51.98-84.143-102.985v-1.299c13.969 7.797 30.214 12.67 47.431 13.319-28.264-18.843-46.781-51.005-46.781-87.391 0-19.492 5.197-37.36 14.294-52.954 51.655 63.675 129.3 105.258 216.365 109.807-1.624-7.797-2.599-15.918-2.599-24.04 0-57.828 46.782-104.934 104.934-104.934 30.213 0 57.502 12.67 76.67 33.137 23.715-4.548 46.456-13.32 66.599-25.34-7.798 24.366-24.366 44.833-46.132 57.827 21.117-2.273 41.584-8.122 60.426-16.243-14.292 20.791-32.161 39.308-52.628 54.253z"></path></svg></a><a href="/rss.xml"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="rss-square" class="svg-inline--fa fa-rss-square fa-w-14 fa-2x " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M400 32H48C21.49 32 0 53.49 0 80v352c0 26.51 21.49 48 48 48h352c26.51 0 48-21.49 48-48V80c0-26.51-21.49-48-48-48zM112 416c-26.51 0-48-21.49-48-48s21.49-48 48-48 48 21.49 48 48-21.49 48-48 48zm157.533 0h-34.335c-6.011 0-11.051-4.636-11.442-10.634-5.214-80.05-69.243-143.92-149.123-149.123-5.997-.39-10.633-5.431-10.633-11.441v-34.335c0-6.535 5.468-11.777 11.994-11.425 110.546 5.974 198.997 94.536 204.964 204.964.352 6.526-4.89 11.994-11.425 11.994zm103.027 0h-34.334c-6.161 0-11.175-4.882-11.427-11.038-5.598-136.535-115.204-246.161-251.76-251.76C68.882 152.949 64 147.935 64 141.774V107.44c0-6.454 5.338-11.664 11.787-11.432 167.83 6.025 302.21 141.191 308.205 308.205.232 6.449-4.978 11.787-11.432 11.787z"></path></svg></a></div><div class="sc-EHOje cieZjZ"><a href="/terms-of-service/">Terms of Service</a><a href="/privacy-policy/">Privacy Policy</a><a href="/alternatives/">Comparisons</a></div><div class="sc-gzVnrw bGXQre"><strong>100% open-source</strong><br/>Dive in at <a href="https://github.com/httptoolkit" target="_blank" rel="noopener noreferrer">github.com/httptoolkit</a></div><div class="sc-bZQynM bKLyNE"><img src="data:image/png;base64,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" alt="Picture of Tim Perry" class="sc-htoDjs cWnjEm"/>Built in Barcelona<br/>by <a href="https://twitter.com/pimterry">Tim Perry</a></div></div></main></div><div id="gatsby-announcer" style="position:absolute;top:0;width:1px;height:1px;padding:0;overflow:hidden;clip:rect(0, 0, 0, 0);white-space:nowrap;border:0" aria-live="assertive" aria-atomic="true"></div></div><script>
  
  function gaOptout(){document.cookie=disableStr+'=true; expires=Thu, 31 Dec 2099 23:59:59 UTC;path=/',window[disableStr]=!0}var gaProperty='UA-117670723-1',disableStr='ga-disable-'+gaProperty;document.cookie.indexOf(disableStr+'=true')>-1&&(window[disableStr]=!0);
  if(!(navigator.doNotTrack == "1" || window.doNotTrack == "1")) {
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  }
  if (typeof ga === "function") {
    ga('create', 'UA-117670723-1', 'auto', {});
      ga('set', 'anonymizeIp', true);
      
      
      }
      </script><script type="text/javascript" src="https://cdn.jsdelivr.net/npm/docsearch.js@2/dist/cdn/docsearch.min.js"></script><script type="text/javascript">var observer = new MutationObserver(function (mutations, instance) {
  var docuSearchElem = document.querySelector('.docsearch-input');
  if (docuSearchElem) {
    docsearch({
      apiKey: "f5b49b1ad3229d305c66fc594c1133a3",
      indexName: "httptoolkit",
      inputSelector: ".docsearch-input",
      debug: false
    });
    instance.disconnect(); // stop observing
    return;
  }
});

// start observing
document.addEventListener("DOMContentLoaded", function() {
  observer.observe(document, {
    childList: true,
    subtree: true
  });
});</script><script id="gatsby-script-loader">/*<![CDATA[*/window.pagePath="/blog/javascript-mitm-proxy-mockttp/";/*]]>*/</script><script id="gatsby-chunk-mapping">/*<![CDATA[*/window.___chunkMapping={"polyfill":["/polyfill-c37380b4ca611c9944be.js"],"app":["/app-fd83417bb9d1609e371b.js"],"component---src-pages-404-jsx":["/component---src-pages-404-jsx-14d34f87291cfc2a10e8.js"],"component---src-pages-alternatives-jsx":["/component---src-pages-alternatives-jsx-c06d0ca7cf71680c8421.js"],"component---src-pages-android-jsx":["/component---src-pages-android-jsx-2141084fce5afc11f476.js"],"component---src-pages-blog-jsx":["/component---src-pages-blog-jsx-bea79ba52f75cc5a4707.js"],"component---src-pages-blog-thank-you-jsx":["/component---src-pages-blog-thank-you-jsx-83ee75c2e802de8b813c.js"],"component---src-pages-charles-alternative-jsx":["/component---src-pages-charles-alternative-jsx-fbea16041cee192cbf68.js"],"component---src-pages-chrome-devtools-alternative-jsx":["/component---src-pages-chrome-devtools-alternative-jsx-304a04a5d1e3af3d171b.js"],"component---src-pages-contact-jsx":["/component---src-pages-contact-jsx-e5db625620902ccbba02.js"],"component---src-pages-docs-jsx":["/component---src-pages-docs-jsx-a51e4fe8fc6e51c7890c.js"],"component---src-pages-electron-jsx":["/component---src-pages-electron-jsx-13ae089040350143ffbc.js"],"component---src-pages-fiddler-alternative-jsx":["/component---src-pages-fiddler-alternative-jsx-fa186408c09d35a33d2d.js"],"component---src-pages-index-jsx":["/component---src-pages-index-jsx-b632a7e68ac1c426bd39.js"],"component---src-pages-java-jsx":["/component---src-pages-java-jsx-f0c8524650440d3b3d15.js"],"component---src-pages-javascript-jsx":["/component---src-pages-javascript-jsx-e560413c83dbf9a815cc.js"],"component---src-pages-keep-me-updated-jsx":["/component---src-pages-keep-me-updated-jsx-f3b87744bef725b91bb3.js"],"component---src-pages-privacy-policy-jsx":["/component---src-pages-privacy-policy-jsx-ce7f60557c16b037423c.js"],"component---src-pages-python-jsx":["/component---src-pages-python-jsx-391feefb5360cc304f40.js"],"component---src-pages-ruby-jsx":["/component---src-pages-ruby-jsx-b90e03e513d73f8c22e5.js"],"component---src-pages-sent-to-computer-jsx":["/component---src-pages-sent-to-computer-jsx-c4bed5c260e89087f464.js"],"component---src-pages-terms-of-service-jsx":["/component---src-pages-terms-of-service-jsx-6b938bd9bc8bbb311773.js"],"component---src-pages-thank-you-jsx":["/component---src-pages-thank-you-jsx-c773f34ebdcc3f7a077e.js"],"component---src-pages-will-it-cors-jsx":["/component---src-pages-will-it-cors-jsx-a02fa42f4f61060c429b.js"],"component---src-templates-doc-jsx":["/component---src-templates-doc-jsx-862fa900bb3154d701ad.js"],"component---src-templates-download-thank-you-jsx":["/component---src-templates-download-thank-you-jsx-65036abb22a8332ee3ed.js"],"component---src-templates-post-jsx":["/component---src-templates-post-jsx-91e87be856aa7dfd57f4.js"],"component---src-templates-pricing-jsx":["/component---src-templates-pricing-jsx-58ffe7eddd16f240b8ae.js"]};/*]]>*/</script><script nomodule src='https://d33wubrfki0l68.cloudfront.net/js/2653e248ece6777aa647b4952be8b685a289886e/polyfill-c37380b4ca611c9944be.js'></script><script async src='https://d33wubrfki0l68.cloudfront.net/bundles/9f21214dff8d3de3b9a59f6356805c6d0da03428.js'></script></body></html>