<!DOCTYPE html><html lang="en"><head><meta charSet="utf-8"/><meta http-equiv="x-ua-compatible" content="ie=edge"/><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"/><style data-href="/styles.d55f0b00584a849e5a53.css" id="gatsby-global-css">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</style><meta name="generator" content="Gatsby 2.32.13"/><style data-styled="snXzu  dHFJiE juhqmw emkjqm gXdVsZ bNBvDS krfJjt dcCAoE bOFCvB hWelvs hCLKhQ bIyjWi gVEnmP cvaXPN cuYzWk hOdKYF dnvYel ksMljO dyaHBV hkbQow cmyIBz KXHvX gBaMfz hOucDX jPtpSf cieZjZ bGXQre bKLyNE cWnjEm" data-styled-version="4.4.1">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</style><style type="text/css">
    .anchor {
      float: left;
      padding-right: 4px;
      margin-left: -20px;
    }
    h1 .anchor svg,
    h2 .anchor svg,
    h3 .anchor svg,
    h4 .anchor svg,
    h5 .anchor svg,
    h6 .anchor svg {
      visibility: hidden;
    }
    h1:hover .anchor svg,
    h2:hover .anchor svg,
    h3:hover .anchor svg,
    h4:hover .anchor svg,
    h5:hover .anchor svg,
    h6:hover .anchor svg,
    h1 .anchor:focus svg,
    h2 .anchor:focus svg,
    h3 .anchor:focus svg,
    h4 .anchor:focus svg,
    h5 .anchor:focus svg,
    h6 .anchor:focus svg {
      visibility: visible;
    }
  </style><script>
    document.addEventListener("DOMContentLoaded", function(event) {
      var hash = window.decodeURI(location.hash.replace('#', ''))
      if (hash !== '') {
        var element = document.getElementById(hash)
        if (element) {
          var offset = element.offsetTop
          // Wait for the browser to finish rendering before scrolling.
          setTimeout((function() {
            window.scrollTo(0, offset - 80)
          }), 0)
        }
      }
    })
  </script><link rel="alternate" type="application/rss+xml" title="HTTP Toolkit RSS Feed" href="/rss.xml"/><title data-react-helmet="true">Intercepting Docker HTTP</title><link data-react-helmet="true" rel="preconnect" href="https://cdn.paddle.com"/><link data-react-helmet="true" rel="preconnect" href="https://checkout.paddle.com"/><link data-react-helmet="true" rel="preconnect" href="https://accounts.paddle.com"/><link data-react-helmet="true" rel="preload" href="https://cdn.jsdelivr.net/npm/docsearch.js@2/dist/cdn/docsearch.min.css" as="style"/><link data-react-helmet="true" rel="preload" href="https://cdn.jsdelivr.net/npm/docsearch.js@2/dist/cdn/docsearch.min.js" as="script"/><link data-react-helmet="true" rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png"/><link data-react-helmet="true" rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png"/><link data-react-helmet="true" rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png"/><link data-react-helmet="true" rel="manifest" href="/site.webmanifest"/><link data-react-helmet="true" rel="mask-icon" href="/safari-pinned-tab.svg" color="#e1421f"/><link data-react-helmet="true" rel="alternate" type="application/rss+xml" href="https://httptoolkit.tech/rss.xml"/><meta data-react-helmet="true" name="msapplication-TileColor" content="#da532c"/><meta data-react-helmet="true" name="theme-color" content="#fafafa"/><meta data-react-helmet="true" name="viewport" content="width=device-width, initial-scale=1"/><meta data-react-helmet="true" property="og:url" content="https://httptoolkit.tech/docs/guides/docker/"/><meta data-react-helmet="true" property="og:type" content="website"/><meta data-react-helmet="true" property="og:image" content="https://httptoolkit.tech/logo-social.png"/><meta data-react-helmet="true" name="twitter:card" content="summary"/><meta data-react-helmet="true" name="twitter:site" content="@httptoolkit"/><meta data-react-helmet="true" name="twitter:creator" content="@pimterry"/><meta data-react-helmet="true" name="twitter:image" content="https://httptoolkit.tech/logo-square.png"/><meta data-react-helmet="true" name="description" content="HTTP Toolkit can automatically intercept, inspect &amp; rewrite traffic from any Docker container. Right now this feature is in beta, and…"/><meta data-react-helmet="true" property="og:title" content="Intercepting Docker HTTP"/><meta data-react-helmet="true" property="og:description" content="HTTP Toolkit can automatically intercept, inspect &amp; rewrite traffic from any Docker container. Right now this feature is in beta, and…"/><meta data-react-helmet="true" name="twitter:title" content="Intercepting Docker HTTP"/><meta data-react-helmet="true" name="twitter:description" content="HTTP Toolkit can automatically intercept, inspect &amp; rewrite traffic from any Docker container. Right now this feature is in beta, and…"/><script data-react-helmet="true" type="application/ld+json">{"@context":"https://schema.org","@type":"SoftwareApplication","image":"https://httptoolkit.tech/logo-square.png","screenshot":"https://httptoolkit.tech/screenshot.png","video":"https://httptoolkit.tech/http-mock-demo.mp4","name":"HTTP Toolkit","description":"Beautiful & open-source tools to debug, test and develop with HTTP(S)","softwareVersion":"1.6.0","operatingSystem":["Windows","Mac","Linux","Android"],"url":"https://httptoolkit.tech/","downloadUrl":"https://httptoolkit.tech/","applicationCategory":"DeveloperApplication","offers":{"@type":"Offer","price":"0"}}</script><link rel="preload" as="font" type="font/woff2" crossorigin="anonymous" href="/static/webfonts/s/lato/v22/S6uyw4BMUTPHjx4wXg.woff2"/><link rel="preload" as="font" type="font/woff2" crossorigin="anonymous" href="/static/webfonts/s/merriweather/v28/u-440qyriQwlOrhSvowK_l5-fCZM.woff2"/><style>@font-face{font-display:swap;font-family:Lato;font-style:normal;font-weight:400;src:url("https://d33wubrfki0l68.cloudfront.net/fcd4136085f2a03481d9958cc6793a5ed98e714c/30113/static/webfonts/s/lato/v22/s6uyw4bmutphjx4wxg.woff2") format("woff2")}@font-face{font-display:swap;font-family:Lato;font-style:normal;font-weight:400;src:url("https://d33wubrfki0l68.cloudfront.net/a7e64df567e19e9a9be13c97f25b5ab3daf5094e/b037a/static/webfonts/s/lato/v22/s6uyw4bmutphjx4wwa.woff") format("woff")}@font-face{font-display:fallback;font-display:swap;font-family:Merriweather;font-family:Courgette;font-style:normal;font-weight:400;src:url("https://d33wubrfki0l68.cloudfront.net/8effd23e482511e249c3f8e91cdc503729b93598/02723/static/webfonts/s/merriweather/v28/u-440qyriqwlorhsvowk_l5-fczm.woff2") format("woff2");src:url("https://d33wubrfki0l68.cloudfront.net/a812852676e3cda04236d04baffa0f022db5e107/6bfba/static/webfonts/l/font") format("woff2")}@font-face{font-display:fallback;font-family:Merriweather;font-style:normal;font-weight:400;src:url("https://d33wubrfki0l68.cloudfront.net/be26c6cac90095764e04954b1e49f8e7aeeb6ab4/19c4d/static/webfonts/s/merriweather/v28/u-440qyriqwlorhsvowk_l5-fczk.woff") format("woff")}@font-face{font-display:swap;font-family:Courgette;font-style:normal;font-weight:400;src:url("https://d33wubrfki0l68.cloudfront.net/a812852676e3cda04236d04baffa0f022db5e107/6bfba/static/webfonts/l/font") format("woff")}</style><link rel="preconnect dns-prefetch" href="https://www.google-analytics.com"/><link rel="sitemap" type="application/xml" href="/sitemap.xml"/><link rel="canonical" href="https://httptoolkit.tech/docs/guides/docker/" data-baseprotocol="https:" data-basehost="httptoolkit.tech"/><link rel="stylesheet" href="https://cdn.jsdelivr.net/npm/docsearch.js@2/dist/cdn/docsearch.min.css"/><link as="script" rel="preload" href="/webpack-runtime-71e046241d7d5cdf707d.js"/><link as="script" rel="preload" href="/framework-c5dc0716c0b2bd661fa9.js"/><link as="script" rel="preload" href="/styles-c4fa86dfd4ad05097eee.js"/><link as="script" rel="preload" href="/d2ec3f50-41b428099539d861b764.js"/><link as="script" rel="preload" href="/9e82d048-dda34e6b7cc3a92e58bf.js"/><link as="script" rel="preload" href="/app-d8ae094ac4221d9a77cf.js"/><link as="fetch" rel="preload" href="/page-data/docs/guides/docker/page-data.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/page-data/sq/d/3132760262.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/page-data/app-data.json" crossorigin="anonymous"/></head><body><div id="___gatsby"><div style="outline:none" tabindex="-1" id="gatsby-focus-wrapper"><main class="sc-kAzzGY snXzu"><div class="sc-bdVaJa dHFJiE"><div class="sc-bwzfXH juhqmw"><div class="sc-htpNat emkjqm"><a class="sc-chPdSV gXdVsZ" href="/"><img src="https://d33wubrfki0l68.cloudfront.net/bf336c12f88430c817226c3a390b970ab29ea5ac/d4a5d/static/logo-5658def669bc8a94ba3d97f752342bd4.svg" alt="HTTP Toolkit"/></a><a href="#menu" class="sc-kGXeez bNBvDS"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="bars" class="svg-inline--fa fa-bars fa-w-14 fa-2x " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M16 132h416c8.837 0 16-7.163 16-16V76c0-8.837-7.163-16-16-16H16C7.163 60 0 67.163 0 76v40c0 8.837 7.163 16 16 16zm0 160h416c8.837 0 16-7.163 16-16v-40c0-8.837-7.163-16-16-16H16c-8.837 0-16 7.163-16 16v40c0 8.837 7.163 16 16 16zm0 160h416c8.837 0 16-7.163 16-16v-40c0-8.837-7.163-16-16-16H16c-8.837 0-16 7.163-16 16v40c0 8.837 7.163 16 16 16z"></path></svg></a><nav id="menu" class="sc-kgoBCf krfJjt"><button class="sc-fjdhpX bOFCvB sc-kpOJdX dcCAoE"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="times" class="svg-inline--fa fa-times fa-w-11 fa-2x " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 352 512"><path fill="currentColor" d="M242.72 256l100.07-100.07c12.28-12.28 12.28-32.19 0-44.48l-22.24-22.24c-12.28-12.28-32.19-12.28-44.48 0L176 189.28 75.93 89.21c-12.28-12.28-32.19-12.28-44.48 0L9.21 111.45c-12.28 12.28-12.28 32.19 0 44.48L109.28 256 9.21 356.07c-12.28 12.28-12.28 32.19 0 44.48l22.24 22.24c12.28 12.28 32.2 12.28 44.48 0L176 322.72l100.07 100.07c12.28 12.28 32.2 12.28 44.48 0l22.24-22.24c12.28-12.28 12.28-32.19 0-44.48L242.72 256z"></path></svg></button><a class="sc-dxgOiQ hWelvs" href="/docs/">Docs</a><a class="sc-dxgOiQ hWelvs" href="/pricing/">Pricing</a><a class="sc-dxgOiQ hWelvs" href="/blog/">Blog</a><a class="sc-dxgOiQ hWelvs" href="/contact/">Contact</a></nav></div></div></div><section class="sc-eerKOB hCLKhQ"><nav class="sc-eLExRp bIyjWi"><div class="sc-lkqHmb cvaXPN sc-eilVRo gVEnmP"><input type="search" placeholder="Search the docs..." class="sc-dnqmqq cuYzWk docsearch-input-sidebar"/></div><ul class="sc-cbkKFq hOdKYF"><li class="sc-krvtoX ksMljO"><button class="sc-fOKMvo dyaHBV"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="chevron-up" class="svg-inline--fa fa-chevron-up fa-w-14 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M240.971 130.524l194.343 194.343c9.373 9.373 9.373 24.569 0 33.941l-22.667 22.667c-9.357 9.357-24.522 9.375-33.901.04L224 227.495 69.255 381.516c-9.379 9.335-24.544 9.317-33.901-.04l-22.667-22.667c-9.373-9.373-9.373-24.569 0-33.941L207.03 130.525c9.372-9.373 24.568-9.373 33.941-.001z"></path></svg> <!-- -->Getting Started</button><ul class="sc-fYiAbW hkbQow"><li class="sc-krvtoX ksMljO"><a class="sc-gHboQg cmyIBz" href="/docs/getting-started/installing/">1. Installing</a></li><li class="sc-krvtoX ksMljO"><a class="sc-gHboQg cmyIBz" href="/docs/getting-started/intercepting/">2. Intercepting</a></li><li class="sc-krvtoX ksMljO"><a class="sc-gHboQg cmyIBz" href="/docs/getting-started/inspecting/">3. Inspecting</a></li><li class="sc-krvtoX ksMljO"><a class="sc-gHboQg cmyIBz" href="/docs/getting-started/rewriting/">4. Rewriting</a></li></ul></li><li class="sc-krvtoX ksMljO"><button class="sc-fOKMvo dyaHBV"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="chevron-up" class="svg-inline--fa fa-chevron-up fa-w-14 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M240.971 130.524l194.343 194.343c9.373 9.373 9.373 24.569 0 33.941l-22.667 22.667c-9.357 9.357-24.522 9.375-33.901.04L224 227.495 69.255 381.516c-9.379 9.335-24.544 9.317-33.901-.04l-22.667-22.667c-9.373-9.373-9.373-24.569 0-33.941L207.03 130.525c9.372-9.373 24.568-9.373 33.941-.001z"></path></svg> <!-- -->Reference</button><ul class="sc-fYiAbW hkbQow"><li class="sc-krvtoX ksMljO"><a class="sc-gHboQg cmyIBz" href="/docs/reference/intercept-page/">The Intercept Page</a></li><li class="sc-krvtoX ksMljO"><a class="sc-gHboQg cmyIBz" href="/docs/reference/view-page/">The View Page</a></li><li class="sc-krvtoX ksMljO"><a class="sc-gHboQg cmyIBz" href="/docs/reference/mock-page/">The Mock Page</a></li><li class="sc-krvtoX ksMljO"><a class="sc-gHboQg cmyIBz" href="/docs/reference/settings-page/">The Settings Page</a></li><li class="sc-krvtoX ksMljO"><a class="sc-gHboQg cmyIBz" href="/docs/reference/amiusing.httptoolkit.tech/">AmIUsing Test Site</a></li></ul></li><li class="sc-krvtoX ksMljO"><button class="sc-fOKMvo dyaHBV"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="chevron-up" class="svg-inline--fa fa-chevron-up fa-w-14 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M240.971 130.524l194.343 194.343c9.373 9.373 9.373 24.569 0 33.941l-22.667 22.667c-9.357 9.357-24.522 9.375-33.901.04L224 227.495 69.255 381.516c-9.379 9.335-24.544 9.317-33.901-.04l-22.667-22.667c-9.373-9.373-9.373-24.569 0-33.941L207.03 130.525c9.372-9.373 24.568-9.373 33.941-.001z"></path></svg> <!-- -->Guides</button><ul class="sc-fYiAbW hkbQow"><li class="sc-krvtoX ksMljO"><a class="sc-gHboQg cmyIBz" href="/docs/guides/android/">Android</a></li><li class="sc-krvtoX ksMljO"><a aria-current="page" class="sc-gHboQg cmyIBz active" href="/docs/guides/docker/">Docker</a></li><li class="sc-krvtoX ksMljO"><a class="sc-gHboQg cmyIBz" href="/docs/guides/subscription-faq/">Subscriptions FAQ</a></li><li class="sc-krvtoX ksMljO"><a class="sc-gHboQg cmyIBz" href="/docs/guides/troubleshooting/">Troubleshooting</a></li></ul></li></ul></nav><article class="sc-jtRlXQ KXHvX"><div class="sc-lkqHmb cvaXPN sc-bGbJRg gBaMfz"><input type="search" placeholder="Search the docs..." class="sc-dnqmqq cuYzWk docsearch-input-mobile"/></div><h1>Intercepting Docker HTTP</h1><em>Help improve these docs <a href="https://github.com/httptoolkit/httptoolkit.tech/blob/master/src/docs/guides/docker.md" target="_blank" rel="noopener noreferrer">on GitHub</a></em><div><p>HTTP Toolkit can automatically intercept, inspect &#x26; rewrite traffic from any Docker container.</p>
<p><strong>Right now this feature is in beta, and enabled for testers only.</strong> If you'd like to test this out, please <a href="/contact">get in touch</a>.</p>
<p>You can intercept HTTP from Docker containers in two ways:</p>
<ul>
<li>By launching an intercepted terminal within HTTP Toolkit, and creating Docker containers or running Docker builds inside that terminal</li>
<li>By launching Docker containers elsewhere, and using the "Attach to Docker container" option in HTTP Toolkit to restart a running container reconfigured for HTTP Toolkit injection.</li>
</ul>
<p>Most of the time it's more convenient to use an intercepted terminal, but attaching to containers can be useful if you need to use a separate tool or workflow to launch your containers.</p>
<p>Read on for a step-by-step guide to intercepting your Docker containers and Docker builds, or feel free to skip to the <a href="#the-technical-details">low-level details of how Docker interception works</a> or tips on <a href="#troubleshooting">how to troubleshoot common Docker issues</a>.</p>
<h2 id="how-to-intercept-http-from-a-docker-container"><a href="#how-to-intercept-http-from-a-docker-container" aria-label="how to intercept http from a docker container permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>How to intercept HTTP from a Docker container</h2>
<p>The easiest way to capture, inspect &#x26; mock traffic from a Docker container is to launch a fresh terminal in HTTP Toolkit, and run Docker commands there.</p>
<p>To get started, click the 'Fresh Terminal' button on the Intercept page in HTTP Toolkit:</p>
<p><span
      class="gatsby-resp-image-wrapper"
      style="position: relative; display: block; margin-left: auto; margin-right: auto; max-width: 304px; "
    >
      <a
    class="gatsby-resp-image-link"
    href="/static/c8f86546c9e596765d46330a89dec743/e3700/fresh-terminal-button.png"
    style="display: block"
    target="_blank"
    rel="noopener"
  >
    <span
    class="gatsby-resp-image-background-image"
    style="padding-bottom: 80.078125%; position: relative; bottom: 0; left: 0; background-image: url('data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABQAAAAQCAIAAACZeshMAAAACXBIWXMAAAsTAAALEwEAmpwYAAACAElEQVQoz3WT6XKqQBCFff8n8pfWXSpXjZFclU2QEWQHkV1hBs0R3Kpiuo5jz8DXpxW6Jxm2qFtLsl1qFy2I0SUXtYf8xvwuIAB7+FK3TpRmSXFoVcZ5kZYHCFusYZwE+/hZOCGWK2ysHk/MrR9a1pbjZuu1KkvSJ8dhlURRli9rlqZN09C6ZpSyy4eeTo3pBeirhx50x3dddzqdDgaD0Wg047g/bQyHw36/n6bp+XwGX1N6rKqqrsEbrs938Mb2UN4PgjiOi6LY7/cAkiTZ7XZRFHmeZ7eBQ0opcPhvXf/hHAbBZDKZz+eapi2XS57n0fhisUCCraqqSFCUMfYKDkNcJoSsVitFUXRDl2VZXamoBVJpA128gt3AsW34wBk34WZRED/+T//OfisrpcgLdFvfAr/5AQsbk9ju4XBI28jz/LJmuRc7b+4vKRTqirZM9RK28NDotzixU3SMpvFok61ZzX52ttzu9DmqiyONyvBjPybZGvmPMK1fBAyjcgcY5l056IiirL4+56tzd+UmvAwgwzJ8j9601hbbpsaL0rC6ObOz6YaPP6xh7C50dWanrEpm8dgotBNrIO/oqLmsFQpEypVoqwJpB0PWTdPzn2V5wdoxPrc8km47N8V/+mRsTKGR8c4RSdKd3nUk72N4EwZGINZCu04ocpHYd0m6DfALzF1oBbojD74AAAAASUVORK5CYII='); background-size: cover; display: block;"
  ></span>
  <img
        class="gatsby-resp-image-image"
        alt="The Fresh Terminal button"
        title="The Fresh Terminal button"
        src="https://d33wubrfki0l68.cloudfront.net/88d8a75cf61bec45a37a804bae8ff96540099ef1/4bdd4/static/c8f86546c9e596765d46330a89dec743/e3700/fresh-terminal-button.png"
        srcset="https://d33wubrfki0l68.cloudfront.net/5678e4755161ef01aa59d1e2288bcbe9ebf6a6e6/6f691/static/c8f86546c9e596765d46330a89dec743/909a8/fresh-terminal-button.png 256w,
https://d33wubrfki0l68.cloudfront.net/88d8a75cf61bec45a37a804bae8ff96540099ef1/4bdd4/static/c8f86546c9e596765d46330a89dec743/e3700/fresh-terminal-button.png 304w"
        sizes="(max-width: 304px) 100vw, 304px"
        style="width:100%;height:100%;margin:0;vertical-align:middle;position:absolute;top:0;left:0;"
        loading="lazy"
      />
  </a>
    </span></p>
<p>This will open a terminal. Any Docker containers created by this terminal will be automatically intercepted. That means you can use commands like <code class="language-text">docker run</code>, <code class="language-text">docker create</code> or even <code class="language-text">docker-compose up</code> to launch containers, and you'll immediately &#x26; automatically intercept all their traffic.</p>
<p>You can test this by launching any container you like. As an example, let's use the <a href="https://hub.docker.com/r/curlimages/curl">official Curl Docker image</a> to make an HTTP request, by running:</p>
<div class="gatsby-highlight" data-language="text">
      <pre class="language-text"><code class="language-text">docker run curlimages/curl https://amiusing.httptoolkit.tech/</code></pre>
      </div>
<p>This will make an HTTP request to AmIUsing.httptoolkit.tech (pulling the curl Docker image, if you don't already have it locally).</p>
<p>If HTTP Toolkit interception is working correctly, you'll see an HTML response including "You're being intercepted by HTTP Toolkit", and you'll see the request appear on the View page inside HTTP Toolkit itself. You can also log the headers with <code class="language-text">-v</code> and you'll see a <code class="language-text">httptoolkit-active: true</code> header sent in every intercepted response.</p>
<p>That's it! <code class="language-text">docker run</code> creates and starts a container, and by running it in this intercepted terminal, the correct settings are injected into the container when it's initially created.</p>
<p>You can test this with other languages too:</p>
<div class="gatsby-highlight" data-language="text">
      <pre class="language-text"><code class="language-text">$ docker run --rm -it node
&gt; require(&#39;https&#39;).get(&#39;https://amiusing.httptoolkit.tech&#39;, (r) =&gt; console.log(r.headers));
/* ... */
{ &#39;content-type&#39;: &#39;text/html&#39;, &#39;httptoolkit-active&#39;: &#39;true&#39; }

$ docker run --rm -it python
&gt; import urllib.request
&gt; urllib.request.urlopen(&quot;https://amiusing.httptoolkit.tech&quot;).read()
#...
&lt;h1&gt;You\&#39;re being intercepted by HTTP Toolkit&lt;/h1&gt;
#...

$ docker run --rm -it php
&gt; print(file_get_contents(&quot;https://amiusing.httptoolkit.tech&quot;));
#...
&lt;h1&gt;You&#39;re being intercepted by HTTP Toolkit&lt;/h1&gt;
#...

$ docker run --rm -it ruby
&gt; require &#39;net/http&#39;
&gt; Net::HTTP.get_print(URI(&quot;https://amiusing.httptoolkit.tech&quot;))
#...
&lt;h1&gt;You&#39;re being intercepted by HTTP Toolkit&lt;/h1&gt;
#...</code></pre>
      </div>
<p>In each case here we're interactively writing code, and making requests with each language's built-in HTTP APIs, but none of that is required. You can run any container that runs any code making HTTP requests any way it likes, and all HTTP &#x26; HTTPS traffic will be automatically intercepted by HTTP Toolkit.</p>
<p>Once you've intercepted some traffic, you're free to do with it as you will: you can inspect the details of your application's traffic up close, add breakpoints, mock out endpoints with fake responses, inject errors &#x26; timeouts, redirect traffic, or anything else you might want to play with.</p>
<h2 id="how-to-intercept-http-from-docker-compose"><a href="#how-to-intercept-http-from-docker-compose" aria-label="how to intercept http from docker compose permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>How to intercept HTTP from Docker Compose</h2>
<p>Just like launching individual containers, Docker Compose interception works totally automatically. Just run <code class="language-text">docker-compose up</code> from an intercepted terminal.</p>
<p>You can test this out right now using the <a href="https://github.com/spring-petclinic/spring-petclinic-microservices">Spring projects's Docker-Compose Java microservices demo</a>, by running:</p>
<div class="gatsby-highlight" data-language="text">
      <pre class="language-text"><code class="language-text">$ git clone git@github.com:spring-petclinic/spring-petclinic-microservices.git
$ cd spring-petclinic-microservices
$ docker-compose up</code></pre>
      </div>
<p>This will pull, build &#x26; start a demo Pet Clinic web app on your machine. This app is intended to demonstrate a fully featured Java Spring setup, powered by a network of 10 containers, including an AngularJS frontend &#x26; API gateway server, 3 backend Java API microservices, an Spring Boot admin server, monitoring infrastructure with Prometheus &#x26; Graphana, request tracing with Zipkin, and config &#x26; discovery services to glue that all together.</p>
<p>All these services communicate over HTTP. As the applications start up, you'll immedaitely see initial failing requests as services test connectivity to one another, then consistently successful responses once the infrastructure is online, followed by periodic health checks requests against each service:</p>
<p><span
      class="gatsby-resp-image-wrapper"
      style="position: relative; display: block; margin-left: auto; margin-right: auto; max-width: 674px; "
    >
      <a
    class="gatsby-resp-image-link"
    href="/static/058df3869b25a36b6bd1cca1c63ef2cc/8d7b2/docker-spring-startup-traffic.png"
    style="display: block"
    target="_blank"
    rel="noopener"
  >
    <span
    class="gatsby-resp-image-background-image"
    style="padding-bottom: 89.0625%; position: relative; bottom: 0; left: 0; background-image: url('data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABQAAAASCAIAAADUsmlHAAAACXBIWXMAAAsTAAALEwEAmpwYAAACRklEQVQ4y22T6W6kMBCEef93i7Sbzc4Jw2FuMOayDZM/+2En0SqK1ELGcnVVV3cHv3+d1TRmTTkoVZRlGEZ13czrOi+rlMM9jOIkieM0jpNHHPMbRo84SXs5jNMcXM6hsUZ2zao1V0mapZloum6aZ1JkQvTkUMqH3bZtf277zkFbG1wud2217FrAvAIpikIOw3KQL/6sxnFwsRoDhjB8jQku95vRWhelAw8izwnO+/MJOWDeQXWw7btxMPMFPp9CbU0nPfOQiTzLc2C85psXBfe808b+j/wEvz30ZspRIkmOI7Rplne9PMBOdtt1ddOM00Sd38Gnt8iBe4p0zAI8Z88s8g/Z2v7EfPoTrVYXgI3pFYZlcZo2bWcP8EIVZVVVTYNqb9VXrB/MVsO8GivVSMF0q6ob2Gh1XpZOS4HzPzKHyC7UJ1gIZqCsagdeUiGSLOOSin4C/40BVwezcWAME52UHoxhuIVnfjC+g6+vl9noyrndD8qLZKrsZg9wXnR9D5jvN+VuSP5cF+Nq1oAHdGa54Ck8vCYXbaNPzCbZ/aj4MNsWXN9Cs1tn2MEMFetBzUwFDaNtnGk4oaaJOSXIRXATRK+vk9a+5u6QfUwY7XHMK/VjftO2dKtuW/SzMzjS9r1UCrfvR59Vt7BVA1uVOm+PBSI3bYfk+f5ObM/nR/hRd7Jvs9X1JBcnOz80V0VVIYSVpAiqoAukIzuXPrT7BreXF7Uu5dTpbW97GUWPJEnZexJTcxRFl+v1erudTudlWfdPWs/8Dz1v7BWy+BqwAAAAAElFTkSuQmCC'); background-size: cover; display: block;"
  ></span>
  <img
        class="gatsby-resp-image-image"
        alt="An example of the initial traffic shown as the containers start up"
        title="An example of the initial traffic shown as the containers start up"
        src="https://d33wubrfki0l68.cloudfront.net/fba82ede93a2761b4eee83b4ca503e52a440adff/18c71/static/058df3869b25a36b6bd1cca1c63ef2cc/8d7b2/docker-spring-startup-traffic.png"
        srcset="https://d33wubrfki0l68.cloudfront.net/386c6951dcc62067aca5a4f97909f0a22d9839b2/8db83/static/058df3869b25a36b6bd1cca1c63ef2cc/228b6/docker-spring-startup-traffic.png 192w,
https://d33wubrfki0l68.cloudfront.net/30cb0ab7ad11ad3d7975dae499dd5141bf591944/e9352/static/058df3869b25a36b6bd1cca1c63ef2cc/06574/docker-spring-startup-traffic.png 384w,
https://d33wubrfki0l68.cloudfront.net/fba82ede93a2761b4eee83b4ca503e52a440adff/18c71/static/058df3869b25a36b6bd1cca1c63ef2cc/8d7b2/docker-spring-startup-traffic.png 674w"
        sizes="(max-width: 674px) 100vw, 674px"
        style="width:100%;height:100%;margin:0;vertical-align:middle;position:absolute;top:0;left:0;"
        loading="lazy"
      />
  </a>
    </span></p>
<p>Starting up the full suite of containers will take a few minutes, but once it's complete you should be able to visit <code class="language-text">http://localhost:8080</code> to view the AngularJS frontend (open it in an intercepted browser via HTTP Toolkit to see your Docker &#x26; web traffic all in one place!).</p>
<p>Click the 'Owners', then 'All' buttons in the menu to dynamically load the list of pet owners in the service, and you'll see in HTTP Toolkit that a browser request is made to <code class="language-text">http://localhost:8080/api/customer/owners</code>, followed by a proxied request to the backend Owners microservice at <code class="language-text">http://&lt;container id>:8081/owners</code>, including tracing ids, and returning the raw JSON for the owner data.</p>
<p>That proxied request might look like this:</p>
<p><span
      class="gatsby-resp-image-wrapper"
      style="position: relative; display: block; margin-left: auto; margin-right: auto; max-width: 577px; "
    >
      <a
    class="gatsby-resp-image-link"
    href="/static/366f51328191a5a8bb834827c77e73dd/e5477/docker-proxied-spring-request.png"
    style="display: block"
    target="_blank"
    rel="noopener"
  >
    <span
    class="gatsby-resp-image-background-image"
    style="padding-bottom: 104.21052631578948%; position: relative; bottom: 0; left: 0; background-image: url('data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABQAAAAVCAIAAADJt1n/AAAACXBIWXMAAAsTAAALEwEAmpwYAAACNklEQVQ4y41Ui5KjIBD0//9wk9uYEFB5K75Q1FyDuZSbS9Vd14SaCvRMzzCYkUpybSttS2X+YdrkrMpJRYUspD4Tlum6mcax7/t5npaIEC18sHUNhVScmaZ13ntCi4wr7ZqIYRj8H0wAgiU7Yklh4GzremOJrKSs69oYo7U2CeBHDQnzG6YZkdd1iWRprBACmfec1lqQlVLOOUTEOo7jO/1IZozleX65XHD0fr8TQoqi0AlghgMg5yfZ1iBfr9eqqnAUKpAWQtq23ZPDQTu7BPh78m1bn2RKqZQSgWMPCbndblABCSihTXAJuzMmoBORjKtCeKnUkLCTEQ7KywTEhf5dAsJBFFZouFGWmcZhD3lwDtvQLBIQCLUhCdZX51/OUzbIgnM0DCHwL+pHcsRCna97Srf+qduqbqqyPJ1O6Bm03RMg1R/m5M2wtexk61rBq/P5nF+vUghGaeqTQ+xPiHMKPY9tIyCTUpRC3ouKlrzkshCSKyO0PRrXZjdlbBwqOLb+xsMglM0h9MM4jNHgJBuONnqPH6olWuTIZWrjHN5iJi6/MBCTj3uvOX6bKlwEbo4y1tJrl391+WkWJZJnWoi6afqh359LSE15A9LvmAZY5/suTCOqyGqonPw89L51YfZhWZHr8dh+2uO4bsnVjYvdnvHM+64+fTnOieqZ6sYpvv2/QjwNEwIyys5s22GCZte4y7dSlsiusr1p/fo/ZO1ah28QqtIqTD6sS8q67Ic+WtqF7OY3lTCsDyGUWVcAAAAASUVORK5CYII='); background-size: cover; display: block;"
  ></span>
  <img
        class="gatsby-resp-image-image"
        alt="An intercepted request from a Spring container"
        title="An intercepted request from a Spring container"
        src="https://d33wubrfki0l68.cloudfront.net/fd5072350c796e62f251055358dd7c2e26813d31/0fbf9/static/366f51328191a5a8bb834827c77e73dd/e5477/docker-proxied-spring-request.png"
        srcset="https://d33wubrfki0l68.cloudfront.net/aa170214ff34dcec62af726c8370c38385a5058f/5b0e6/static/366f51328191a5a8bb834827c77e73dd/b3157/docker-proxied-spring-request.png 190w,
https://d33wubrfki0l68.cloudfront.net/ec77df845c1b360a10b2e8b7344e0e8442776ec0/bb35f/static/366f51328191a5a8bb834827c77e73dd/00ba7/docker-proxied-spring-request.png 381w,
https://d33wubrfki0l68.cloudfront.net/fd5072350c796e62f251055358dd7c2e26813d31/0fbf9/static/366f51328191a5a8bb834827c77e73dd/e5477/docker-proxied-spring-request.png 577w"
        sizes="(max-width: 577px) 100vw, 577px"
        style="width:100%;height:100%;margin:0;vertical-align:middle;position:absolute;top:0;left:0;"
        loading="lazy"
      />
  </a>
    </span></p>
<p>All data running in this service is totally local, so feel free to edit owners, create new pets and record pet visits to the clinic to see the traffic that's sent between these microservices under the hood.</p>
<p>You can also try visiting the interfaces of the other components, such as the admin server at <code class="language-text">http://localhost:9090</code>. Once your containers have started, this should show all containers up and running. If you want, you can mess with this too by adding a mock rule to fail health checks:</p>
<p><span
      class="gatsby-resp-image-wrapper"
      style="position: relative; display: block; margin-left: auto; margin-right: auto; max-width: 1008px; "
    >
      <a
    class="gatsby-resp-image-link"
    href="/static/fb710b15a8c729150a8574fa3746ed08/15f14/docker-healthcheck-rule.png"
    style="display: block"
    target="_blank"
    rel="noopener"
  >
    <span
    class="gatsby-resp-image-background-image"
    style="padding-bottom: 24.409448818897637%; position: relative; bottom: 0; left: 0; background-image: url('data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABQAAAAFCAIAAADKYVtkAAAACXBIWXMAAAsTAAALEwEAmpwYAAAA7UlEQVQY0x1Q226DMAzl/9/3A/uRadPeKzUBNoiqQaDcAsROcKCj7cyOrKMjX45lR3lTOecBvQUHiBbQ+WWh4JfgKbDmDKeAFRH4YGZQzZy3VhuMZKG6pkVE4hFamAMRhfC7rY/7DQC6rvXecYNzCGzNWIideEF0UmkiYyllXdd933fc23Z2HD7l5V2Ws+nPQnBVCJGmKXOWZde61loPwxDFhSp/imtzwBgzTdMwjjvh60fy8vb9fD4s34MHtm29bQdCCOsa7vsenfKvs5AiToSMM6XKqiq0Zk6z/FKWfO0MYPkXiCz+4/gLx2ThD5w7Ekk0+KToAAAAAElFTkSuQmCC'); background-size: cover; display: block;"
  ></span>
  <img
        class="gatsby-resp-image-image"
        alt="A mock rule that close the connection whenever a health check request is sent"
        title="A mock rule that close the connection whenever a health check request is sent"
        src="https://d33wubrfki0l68.cloudfront.net/5bfb4fdbb8eaf0a0c605ee31f93795b30df5b68f/8c700/static/fb710b15a8c729150a8574fa3746ed08/15f14/docker-healthcheck-rule.png"
        srcset="https://d33wubrfki0l68.cloudfront.net/fc1adb5f086b5dcfe808b37e573d175cc04ce268/f014c/static/fb710b15a8c729150a8574fa3746ed08/9d6e2/docker-healthcheck-rule.png 254w,
https://d33wubrfki0l68.cloudfront.net/e13069656bc26bacbcd00b4a197efdccafd07a3b/e60de/static/fb710b15a8c729150a8574fa3746ed08/01ff7/docker-healthcheck-rule.png 512w,
https://d33wubrfki0l68.cloudfront.net/5bfb4fdbb8eaf0a0c605ee31f93795b30df5b68f/8c700/static/fb710b15a8c729150a8574fa3746ed08/15f14/docker-healthcheck-rule.png 1008w"
        sizes="(max-width: 1008px) 100vw, 1008px"
        style="width:100%;height:100%;margin:0;vertical-align:middle;position:absolute;top:0;left:0;"
        loading="lazy"
      />
  </a>
    </span></p>
<p>(<a href="/get-pro">HTTP Toolkit Pro</a> is required to add automated response rules like this, but you can do the same manually using the "Pause the request to manually edit it" option and manually killing health check requests)</p>
<p>You should quickly see failing requests on the View page, and when you refresh the admin server's status page it will show the entire infrastructure going offline:</p>
<p><span
      class="gatsby-resp-image-wrapper"
      style="position: relative; display: block; margin-left: auto; margin-right: auto; max-width: 932px; "
    >
      <a
    class="gatsby-resp-image-link"
    href="/static/cebb3bbbb1ef73c40605c522d98bfa35/071b8/docker-healthcheck-failure.png"
    style="display: block"
    target="_blank"
    rel="noopener"
  >
    <span
    class="gatsby-resp-image-background-image"
    style="padding-bottom: 64.43514644351464%; position: relative; bottom: 0; left: 0; background-image: url('data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABQAAAANCAIAAAAmMtkJAAAACXBIWXMAAAsTAAALEwEAmpwYAAABM0lEQVQoz5WSbUuEQBCA/TOS5wVdgUV9CqLzQ5/77/muUAemd6fjuqz7ZnNKZQeX3MO67M7wMOOwxu3ry9P62V2vXdfFz3Ec0zQvBizLwv1yYHVz/Xj/cHe1WiyXeLVt27IXRpQmWZalaZokCe5xHPu+Hwx4nofnMAyDMIyjKIrjN8/DhalDMAiM/hsA0Fr3E9q2lVJOI5pxzbqfqyGV0gOMMTVhjKD8J8SFwqX1GDCE4IJzycVYVp+DUQNsPvP3It9TwrTU/W/ncqA/wUGmlO4IFKRuREeVmP72vIxTKaEqoALOiOrOq4wymjnsN7uiZnSaRlMI8a9MaQl12dSNZNj2kTxXmdJtA1sCDT/I+iyZEJJXu499uWWEKH40sJm2Mc2kYEpQnDbv5ARMcXwCJ8BH8gUmIsk/57HGoQAAAABJRU5ErkJggg=='); background-size: cover; display: block;"
  ></span>
  <img
        class="gatsby-resp-image-image"
        alt="The Spring service healthcheck failing due to our mock rules"
        title="The Spring service healthcheck failing due to our mock rules"
        src="https://d33wubrfki0l68.cloudfront.net/6e787494848c569109f861bc142abd35a0472a70/70702/static/cebb3bbbb1ef73c40605c522d98bfa35/071b8/docker-healthcheck-failure.png"
        srcset="https://d33wubrfki0l68.cloudfront.net/c608e36b6cd932f2f403eae1d30f0b0848c72578/c720b/static/cebb3bbbb1ef73c40605c522d98bfa35/dee48/docker-healthcheck-failure.png 239w,
https://d33wubrfki0l68.cloudfront.net/f73dd4241ae255e5fc445d6dfbbb686582acca01/9da8d/static/cebb3bbbb1ef73c40605c522d98bfa35/90d3d/docker-healthcheck-failure.png 479w,
https://d33wubrfki0l68.cloudfront.net/6e787494848c569109f861bc142abd35a0472a70/70702/static/cebb3bbbb1ef73c40605c522d98bfa35/071b8/docker-healthcheck-failure.png 932w"
        sizes="(max-width: 932px) 100vw, 932px"
        style="width:100%;height:100%;margin:0;vertical-align:middle;position:absolute;top:0;left:0;"
        loading="lazy"
      />
  </a>
    </span></p>
<p>HTTP Toolkit can intercept and rewrite traffic like this for any Docker or Docker Compose project, to automatically inspect, debug, and mock any HTTP or HTTPS traffic you like.</p>
<h2 id="how-to-intercept-http-from-a-running-docker-container"><a href="#how-to-intercept-http-from-a-running-docker-container" aria-label="how to intercept http from a running docker container permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>How to intercept HTTP from a running Docker container</h2>
<p>In most cases, launching containers from an intercepted terminal is the easiest way to intercept them. If that's not possible for your workflow though, it's possible to intercept containers launched elsewhere.</p>
<p>To test this out, first start up a Docker container that's not intercepted. For example, you can start the Docker Compose microservices demo used above from a separate (non-HTTP Toolkit) terminal, like so:</p>
<div class="gatsby-highlight" data-language="text">
      <pre class="language-text"><code class="language-text">$ git clone git@github.com:spring-petclinic/spring-petclinic-microservices.git
$ cd spring-petclinic-microservices
$ docker-compose up</code></pre>
      </div>
<p>This should successfully launch these containers so that (after a minute or two) you can use the app from <code class="language-text">http://localhost:8080</code>. At this point, nothing should appear in HTTP Toolkit.</p>
<p>You can then intercept this by clicking the "Attach to Docker Container" option on the Intercept page in HTTP Toolkit. Clicking this button will show a list of the currently running containers on your machine:</p>
<p><span
      class="gatsby-resp-image-wrapper"
      style="position: relative; display: block; margin-left: auto; margin-right: auto; max-width: 279px; "
    >
      <a
    class="gatsby-resp-image-link"
    href="/static/0830dd7d1a7d890b511b29d977c66f09/a776c/docker-container-attach-selection.png"
    style="display: block"
    target="_blank"
    rel="noopener"
  >
    <span
    class="gatsby-resp-image-background-image"
    style="padding-bottom: 179.29687499999997%; position: relative; bottom: 0; left: 0; background-image: url('data:image/png;base64,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'); background-size: cover; display: block;"
  ></span>
  <img
        class="gatsby-resp-image-image"
        alt="A list of the Docker containers from the Spring Microservices demo"
        title="A list of the Docker containers from the Spring Microservices demo"
        src="https://d33wubrfki0l68.cloudfront.net/485d4154e852d91550ae296a92663149e2037b3c/d9e61/static/0830dd7d1a7d890b511b29d977c66f09/a776c/docker-container-attach-selection.png"
        srcset="https://d33wubrfki0l68.cloudfront.net/b91aaed4697cf910cd546f726e7f6dc6389776d3/ee24c/static/0830dd7d1a7d890b511b29d977c66f09/9689c/docker-container-attach-selection.png 256w,
https://d33wubrfki0l68.cloudfront.net/485d4154e852d91550ae296a92663149e2037b3c/d9e61/static/0830dd7d1a7d890b511b29d977c66f09/a776c/docker-container-attach-selection.png 279w"
        sizes="(max-width: 279px) 100vw, 279px"
        style="width:100%;height:100%;margin:0;vertical-align:middle;position:absolute;top:0;left:0;"
        loading="lazy"
      />
  </a>
    </span></p>
<p>Click any one of these containers to restart it with HTTP Toolkit's settings injected. Once it restarts, you'll should start seeing the intercepted traffic from that container on the View page. You can intercept as many containers as you like, depending on which you're most interested in.</p>
<p>When using Docker Compose and other similar tools, your existing attached Docker session will persist as long as at least one of the containers is still running, and as you restart containers Docker Compose will re-attach to the output of each container, so you can still see logs as normal.</p>
<p>In some other environments, such as when running an individual container with Docker, restarting the container like this may detach you from the container's output. To re-attach to the restarted container you can use <code class="language-text">docker attach &lt;container id></code> in any terminal.</p>
<h2 id="how-to-intercept-http-from-a-docker-build"><a href="#how-to-intercept-http-from-a-docker-build" aria-label="how to intercept http from a docker build permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>How to intercept HTTP from a Docker build</h2>
<p>In addition to debugging running containers, HTTP Toolkit also allows you to intercept Docker builds. This lets you explore exactly what HTTP requests your Docker build is making, and test out failure scenarios or alternative inputs.</p>
<p>To do this, launch an intercepted terminal from HTTP Toolkit, and then run your build there using <code class="language-text">docker build</code>.</p>
<p>At the start of your build (or the start of each stage, in multi-stage builds), you'll see an extra step added by HTTP Toolkit, followed by the rest of your build output. For a simple Go build, that might look like this:</p>
<div class="gatsby-highlight" data-language="bash">
      <pre class="language-bash"><code class="language-bash">$ docker build <span class="token builtin class-name">.</span>
Sending build context to Docker daemon  <span class="token number">3</span>.072kB
Step <span class="token number">1</span>/4 <span class="token builtin class-name">:</span> FROM golang:1.16
 ---<span class="token operator">></span> 71f1b47263fc
<span class="gatsby-highlight-code-line"> *** Enabling HTTP Toolkit interception ***
</span> ---<span class="token operator">></span> b8f231d31098
Step <span class="token number">2</span>/4 <span class="token builtin class-name">:</span> COPY <span class="token builtin class-name">.</span> <span class="token builtin class-name">.</span>
 ---<span class="token operator">></span> e2103cef8df8
Step <span class="token number">3</span>/4 <span class="token builtin class-name">:</span> RUN go build app.go
 ---<span class="token operator">></span> Running <span class="token keyword">in</span> fda11e0705c1
Removing intermediate container fda11e0705c1
 ---<span class="token operator">></span> 883a818d1216
Step <span class="token number">4</span>/4 <span class="token builtin class-name">:</span> ENTRYPOINT <span class="token punctuation">[</span><span class="token string">"./app"</span><span class="token punctuation">]</span>
 ---<span class="token operator">></span> Running <span class="token keyword">in</span> 0155c41044a3
Removing intermediate container 0155c41044a3
 ---<span class="token operator">></span> 288dc90a4c02
Successfully built 288dc90a4c02</code></pre>
      </div>
<p>Other than this extra injection step, your build will run as normal, but with all HTTP and HTTPS traffic automatically redirected and captured by HTTP Toolkit.</p>
<h2 id="troubleshooting"><a href="#troubleshooting" aria-label="troubleshooting permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Troubleshooting</h2>
<h3 id="docker-support-is-not-available"><a href="#docker-support-is-not-available" aria-label="docker support is not available permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Docker support is not available</h3>
<p>If HTTP Toolkit can't successfully connect to Docker, the "Attach to Docker Container" button will be deactivated and running Docker commands in an intercepted terminal will fail.</p>
<p>HTTP Toolkit attempts to connect to Docker at startup to detect whether it's available. By default the standard local pipe connections for each platform are used (<code class="language-text">//./pipe/docker_engine</code> on Linux and Mac or <code class="language-text">/var/run/docker.sock</code> on Windows).</p>
<p>These settings can be overridden by starting HTTP Toolkit in an environment with the standard Docker env vars set to configure the connection. To do so, start HTTP Toolkit with the standard <code class="language-text">DOCKER_HOST</code> environment variable set to the address of your Docker daemon. You can also use the <code class="language-text">DOCKER_TLS_VERIFY</code> and <code class="language-text">DOCKER_CERT_PATH</code> options if your Docker daemon uses TLS.</p>
<h3 id="starting-an-preexisting-container-in-an-intercepted-terminal-fails"><a href="#starting-an-preexisting-container-in-an-intercepted-terminal-fails" aria-label="starting an preexisting container in an intercepted terminal fails permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Starting an preexisting container in an intercepted terminal fails</h3>
<p>HTTP Toolkit can only intercept containers at creation time, so it's not possible to intercept an existing non-intercepted container that was created elsewhere.</p>
<p>To avoid cases where this might happen unexpectedly, launching a container like this in an intercepted terminal will fail immediately, showing a message like:</p>
<div class="gatsby-highlight" data-language="text">
      <pre class="language-text"><code class="language-text">Error response from daemon:
HTTP Toolkit cannot intercept startup of preexisting non-intercepted containers.
The container must be recreated here first - try `docker run &lt;image&gt;` instead.
Error: failed to start containers: &lt;your image id&gt;</code></pre>
      </div>
<p>To avoid this, you can either launch the container elsewhere and then intercept is using the "Attach to a Docker Container" button in HTTP Toolkit, or you can recreate the container in the intercepted terminal, by either:</p>
<ul>
<li>Creating &#x26; starting a new container with <code class="language-text">docker run &lt;image></code></li>
<li>By manually recreating the container with <code class="language-text">docker create &lt;image></code> and then starting it with `docker</li>
</ul>
<h3 id="intercepted-images-and-containers-disappear-after-http-toolkit-exits"><a href="#intercepted-images-and-containers-disappear-after-http-toolkit-exits" aria-label="intercepted images and containers disappear after http toolkit exits permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Intercepted images and containers disappear after HTTP Toolkit exits</h3>
<p>All intercepted containers &#x26; images contain persistent configuration that changes the proxy settings and trusted certificates, so that traffic can be intercepted. Unfortunately, this means that when HTTP Toolkit exits, they generally become unusuable, because all their network traffic is redirected through a proxy that's no longer running.</p>
<p>To avoid this causing issues, and ensure that usage elsewhere always recreates everything fresh with no interception settings leftover, all Docker containers &#x26; images and automatically stopped and deleted when HTTP Toolkit exits.</p>
<p>If you have a specific reason that you need to preserve this data, you can do so using <code class="language-text">docker commit &lt;container></code> to preserve the state of a container as a new image that can be run elsewhere, or <code class="language-text">docker image save &lt;image> -o &lt;filename></code> to back up an existing image as a file on disk.</p>
<h3 id="docker-buildkit-builds-cant-be-intercepted"><a href="#docker-buildkit-builds-cant-be-intercepted" aria-label="docker buildkit builds cant be intercepted permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Docker BuildKit builds can't be intercepted</h3>
<p>This is a known issue right now: HTTP Toolkit can't yet intercept BuildKit builds, so in intercepted terminals BuildKit is disabled so that Docker falls back to standard builds.</p>
<p>BuildKit is still disabled by default in many other environments anyway, so this should not be a problem for the vast majority of builds, unless you depend on some specific BuildKit functionality.</p>
<p>If this feature is important to you, please <a href="https://github.com/httptoolkit/httptoolkit/issues/new">file an issue</a> with more details, so supporting this can be prioritized.</p>
<h2 id="the-technical-details"><a href="#the-technical-details" aria-label="the technical details permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>The Technical Details</h2>
<h3 id="overview"><a href="#overview" aria-label="overview permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Overview</h3>
<p>Making all of this work smoothly is quite complicated, as you might imagine. A quick summary is that:</p>
<ul>
<li>We need to inject some extra files &#x26; environment variables into containers &#x26; images when they're first created/built.</li>
<li>We can do this by transforming container creation config and image Dockerfiles.</li>
<li>Docker attachment works by connecting to Docker, cloning a container, making these transformations, and starting the transformed container.</li>
<li>To intercept Docker clients in terminals, HTTP Toolkit runs a Docker proxy when Docker is available, and reroutes Docker clients to use it as their Docker daemon.</li>
<li>The Docker proxy rewrites Docker API requests to inject extra settings into new containers &#x26; builds, and rewrites API responses to convince Docker Compose not to reuse non-intercepted containers.</li>
<li>To provide inter-container connectivity, a Docker SOCKS tunnel container is launched, and an internal Docker-only DNS server is used to map hostnames and aliases to IPs the tunnel can reach.</li>
</ul>
<p>Read on to dig into the details:</p>
<h3 id="interception-requirements"><a href="#interception-requirements" aria-label="interception requirements permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Interception requirements</h3>
<p>HTTP Toolkit interception requires two things:</p>
<ul>
<li>Redirecting HTTP &#x26; HTTPS traffic to HTTP Toolkit</li>
<li>Ensuring that HTTPS connections trust HTTP Toolkit's certificate</li>
</ul>
<p>HTTP Toolkit intercepts command-line applications in terminals by using a combination of environment variables to temporarily inject extra configuration and files into applications run in that session.</p>
<p>For simple cases, HTTP Toolkit sets variables like the <code class="language-text">HTTP_PROXY</code> environment variable (used by many applications to detect proxy settings) and the <code class="language-text">SSL_CERT_FILE</code> variable (used by many applications, especially anything based on OpenSSL, to find trusted CA certificates). For more complex cases like JVM applications, variables like <code class="language-text">JAVA_TOOL_OPTIONS</code> are used - this allows HTTP Toolkit to set a <code class="language-text">-javaagent</code> JVM option that loads a <a href="https://github.com/httptoolkit/jvm-http-proxy-agent/">custom JVM agent</a> which reconfigures proxy and certificate settings inside any JVMs that are started.</p>
<p>You can see the full list of environment variables used <a href="https://github.com/httptoolkit/httptoolkit-server/blob/cf136585cb0ef840d94e5ba8a4c03323523f5d67/src/interceptors/terminal/terminal-env-overrides.ts#L64-L136">here</a>.</p>
<p>To intercept Docker applications, HTTP Toolkit does the same thing, but by modifying containers &#x26; images to set extra environment variables when they're created, and to add the extra files required (like the CA certificate, and the JVM agent JAR) into the filesystem at <code class="language-text">/http-toolkit-injections</code>.</p>
<p>There's two ways that this image/container modification &#x26; interception happens:</p>
<ol>
<li>By using a Docker API proxy to rewrite Docker commands in terminals</li>
<li>By connecting to Docker, and cloning a running container with new settings, when attaching to running containers</li>
</ol>
<p>We'll look first at the details of these modifications, and then talk about how the proxy &#x26; container attach systems apply it.</p>
<h3 id="modifying-docker-containers"><a href="#modifying-docker-containers" aria-label="modifying docker containers permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Modifying Docker containers</h3>
<p>So, to intercept a container or build we need to inject some extra files &#x26; env vars. We can do all this entirely within the container configuration (not normally something you touch as a Docker end user, but visible using <code class="language-text">docker inspect &lt;container></code> if you're interested). The full modifications are:</p>
<ul>
<li>In <code class="language-text">Config.HostConfig.Binds</code> we add binds which mount your local HTTP Toolkit CA certificate and the various <a href="https://github.com/httptoolkit/httptoolkit-server/tree/9f54ca6/overrides">override files</a> inside the container.</li>
<li>On Linux, in <code class="language-text">Config.HostConfig.ExtraHosts</code>, we map <code class="language-text">host.docker.internal</code> to the host IP address (this is built into Docker on Windows &#x26; Mac, but not Linux) so we can reach HTTP Toolkit at that address on all platforms.</li>
<li>In <code class="language-text">Config.Env</code> we append all our terminal env vars, remapping references to override paths to the mounted override files</li>
<li>In <code class="language-text">Config.Labels</code> we add a <code class="language-text">tech.httptoolkit.docker.proxy=$YOUR_PROXY_PORT</code> label, so we can tell which containers are intercepted by which proxy.</li>
<li>If <code class="language-text">Config.Labels</code> contains a <code class="language-text">com.docker.compose.config-hash</code> label (i.e. if Docker Compose is managing the container) then we change the value and append <code class="language-text">+httptoolkit:$YOUR_PROXY_PORT</code> to the hash. This ensures your normal Docker Compose won't use this image outside intercepted environments, and lets us remap it so that it does get used by in the appropriate intercepted Docker Compose environment (more on that under 'Intercepting Docker Compose' later).</li>
</ul>
<p>This doesn't ever actually modify existing containers configuration (that's not generally possible). Instead, we take an existing configuration, copy &#x26; modify that, and then create a totally new container with the new config.</p>
<p>The full code for this transformation is <a href="https://github.com/httptoolkit/httptoolkit-server/blob/9f54ca6/src/interceptors/docker/docker-commands.ts#L94-L187">here</a>.</p>
<h3 id="modifying-docker-images"><a href="#modifying-docker-images" aria-label="modifying docker images permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Modifying Docker images</h3>
<p>The above changes work for individual containers. To intercept traffic from builds, we have to inject the same env vars &#x26; files into the build process itself.</p>
<p>To do so, we intercept Docker builds using the Docker proxy (see below). By proxying the build traffic, we can add extra files into the build context, and add a few extra lines to the Dockerfile at the start of each build stage:</p>
<ul>
<li>A <code class="language-text">LABEL tech.httptoolkit.docker.build-proxy=started-$YOUR_PROXY_PORT</code> step (note the <code class="language-text">started-</code> prefix) so that we can recognize which build is being intercepted by which proxy.</li>
<li>A <code class="language-text">COPY</code> step that copies in the HTTP Toolkit CA certificate and the various <a href="https://github.com/httptoolkit/httptoolkit-server/tree/9f54ca6/overrides">override files</a> from the build context.</li>
<li>An <code class="language-text">ENV</code> step for <a href="https://github.com/httptoolkit/httptoolkit-server/blob/9f54ca6/src/interceptors/terminal/terminal-env-overrides.ts#L64-L136">each environment variable</a> that's required.</li>
<li>A <code class="language-text">LABEL tech.httptoolkit.docker.build-proxy=$YOUR_PROXY_PORT</code> step, replacing the previous label, so we can recognize which built images are being intercepted by which proxy.</li>
</ul>
<p>This creates a lot of extra steps at the start of each build stage! Fortunately they're small and fast, and to avoid confusing console noise the Docker proxy (see below) strips these out of the build console output, turning them into a single HTTP Toolkit setup step.</p>
<h3 id="the-docker-proxy"><a href="#the-docker-proxy" aria-label="the docker proxy permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>The Docker Proxy</h3>
<p>To apply these transformations, we need to control how Docker clients use the Docker daemon, so we can modifying how they create containers and start builds.</p>
<p>Docker consists of two main components: a Docker client and a Docker daemon. The Docker daemon handles all the internals of building, running and managing containers, while the Docker client provides a command-line interface to send commands to the daemon.</p>
<p>While the daemon is required, the client is optional, and there's many clients available - the <code class="language-text">docker</code> command is one client, but <code class="language-text">docker-compose</code> is a totally independent client, and tools with Docker integrations available like Visual Studio Code include their own Docker clients.</p>
<p>These Docker clients all talk to the Docker daemon over HTTP. To create the its hooks into Docker containers and intercept traffic, HTTP Toolkit proxies each Docker client's communication with the Docker daemon, and transforms how some API requests work.</p>
<p>It does this by running a local HTTP server, and setting the <code class="language-text">DOCKER_HOST</code> environment variable to redirect Docker daemon API traffic there. This server is our Docker proxy (full code <a href="https://github.com/httptoolkit/httptoolkit-server/blob/9f54ca6/src/interceptors/docker/docker-proxy.ts">here</a>). That env var is set in all intercepted terminals, and so any process started there will inherit it and talk to HTTP Toolkit's Docker proxy instead of the real Docker daemon when it wants to do something with Docker.</p>
<p>The Docker proxy transforms requests in a few ways:</p>
<ul>
<li>When containers are created (<code class="language-text">POST /containers/create</code>) it modifies the client's container config (as above) to add our settings.</li>
<li>When a container is started (<code class="language-text">POST /containers/$id/start</code>) we inspect the container first, and we return an error if it's not intercepted (to avoid unexpectedly starting an unintercepted container in an intercepted environment).</li>
<li>
<p>When a build is started (<code class="language-text">POST /build</code>):</p>
<ol>
<li>We transform the streamed Docker context in the request, to add in our extra files and modify the Dockerfile (as above) to add our extra build steps</li>
<li>We transform the streamed build output, to replace everything between the <code class="language-text">LABEL tech.httptoolkit.docker.build-proxy</code> steps with output that just says <code class="language-text">*** Enabling HTTP Toolkit interception ***</code>, and update all the step count numbers (1/6, 2/6, 3/6...) to match, so that HTTP Toolkit setup isn't counted and your steps match your non-intercepted builds.</li>
</ol>
</li>
<li>When a container is inspected (<code class="language-text">GET /containers/$id/json</code>) or all containers are listed (<code class="language-text">GET /containers/json</code>) we transform the response to replace Docker Compose's container labels, so that only the intercepted containers have the correct hash (see 'Intercepting Docker Compose' below)</li>
<li>For any other requests, we just stream the request &#x26; response directly between the Docker daemon, so everything runs as normal.</li>
</ul>
<h3 id="attaching-to-containers"><a href="#attaching-to-containers" aria-label="attaching to containers permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Attaching to containers</h3>
<p>Attaching to container is far simpler than the Docker proxy. To intercept a running container, HTTP Toolkit:</p>
<ol>
<li>Connects to the Docker daemon.</li>
<li>Gets the config of the target container.</li>
<li>Transforms that config to inject our settings (as above).</li>
<li>Stops &#x26; removes the target container.</li>
<li>Creates the new container from our transformed config.</li>
<li>Starts up the new container and reconnects the appropriate networks.</li>
</ol>
<h3 id="intercepting-docker-compose"><a href="#intercepting-docker-compose" aria-label="intercepting docker compose permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Intercepting Docker Compose</h3>
<p>In theory, intercepting Docker Compose is no different to intercepting any other Docker client, and everything should work with just the container &#x26; image modifications above when Docker Compose commands are run in an intercepted terminal.</p>
<p>In practice, that's true in a completely fresh environment, but not in real-world scenarios. The challenge is that if you already have a container which was built from your <code class="language-text">docker-compose.yml</code> and there's been no modifications, Docker Compose won't recreate the container. That creates two problems: first, there's no container creation for HTTP Toolkit to hook into when you run <code class="language-text">docker-compose up</code> in an intercepted terminal, if your containers are already up to date, and second if you run <code class="language-text">docker-compose up</code> in a non-intercepted terminal it'll reuse intercepted containers, which will a) be very surprising and b) probably break things.</p>
<p>Docker Compose implements this by hashing the project's config file, and storing that hash in a <code class="language-text">com.docker.compose.config-hash</code> label on each container. When you run <code class="language-text">docker-compose up</code>, it compares the hash to the running containers, and it doesn't recreate them if it still matches.</p>
<p>To work around this, HTTP Toolkit remaps the hashes:</p>
<ul>
<li>When a container is created through the Docker proxy with a hash, HTTP Toolkit appends <code class="language-text">+httptoolkit:$YOUR_PROXY_PORT</code> to the config hash. This means that intercepted containers queried from non-intercepted terminals have a mismatched hash, so Docker Compose usage elsewhere never reuses the container.</li>
<li>When a container query is sent via the Docker proxy (e.g. when Docker Compose runs in an intercepted terminal, and checks to see if it needs to recreate a container) we remove the <code class="language-text">+httptoolkit:$PORT</code> suffix, when the port matches, and we add a <code class="language-text">+unintercepted</code> suffix for all containers that have a hash with no suffix at all (i.e. containers created elsewhere).</li>
</ul>
<p>This means that Docker Compose in an intercepted environment sees every container as having the correct hash only if it was intercepted when it was created. If it wasn't intercepted, it'll have an <code class="language-text">+unintercepted</code> suffix, so Docker Compose will see a hash mismatch, and recreate the container from scratch, at which point the container creation hooks in the proxy can kick in and inject the required files &#x26; env vars to intercept the container.</p>
<p>Meanwhile, in a non-intercepted environment, all intercepted containers have invalid hashes and will never be used.</p>
<h3 id="docker-connectivity"><a href="#docker-connectivity" aria-label="docker connectivity permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Docker Connectivity</h3>
<p>There's one last area that's worth mentioning: how does HTTP Toolkit route traffic back into Docker containers when intercepting traffic between containers that are running on their private Docker networks?</p>
<p>When Docker containers are connected to a network, they can send traffic to other containers on that network using the target container's hostname, its IP addresses, any container aliases that were defined when it joined the network, or the names of any container links that are in use (container linking is now deprecated, but people still use it).</p>
<p>To proxy this inter-container traffic, HTTP Toolkit has to be able to correctly route requests to all those addresses.</p>
<p>To do so, HTTP Toolkit first monitors the Docker daemon (by listening to its event stream, and querying the state when things change). This ensures that HTTP Toolkit knows which intercepted containers are running at any time, and which networks those are connected to. It then queries Docker for the details of those networks, so which gives us a full list of all possible destinations of intercepted inter-container traffic.</p>
<p>Given this information, there's two problems:</p>
<ul>
<li>We need to map the possible names of these hosts to their correct IP addresses.</li>
<li>On Windows &#x26; Mac, containers run inside a VM, where container addresses are never routable from the host machine.</li>
</ul>
<p>To solve the first problem, HTTP Toolkit runs its own internal DNS server. This uses the raw network &#x26; container data monitored above to resolve Docker container names, aliases and container link names back to their correct IP addresses.</p>
<p>To solve the second problem, HTTP Toolkit runs a <a href="https://hub.docker.com/repository/docker/httptoolkit/docker-socks-tunnel/">SOCKS tunnel container</a>, and ensures that it's always connected to every network that contains an intercepted container. This tunnel is started when HTTP Toolkit starts up. When traffic is proxied, if it matches any known container name, then the name is resolved and traffic is proxied to the corresponding IP address via this SOCKS tunnel. Since the tunnel is on the same networks as all possible destination containers, it can reliably route traffic to containers on all OSs.</p></div><em>Edit this page <a href="https://github.com/httptoolkit/httptoolkit.tech/blob/master/src/docs/guides/docker.md" target="_blank" rel="noopener noreferrer">on GitHub</a></em></article></section><div class="sc-bxivhb hOucDX"><div class="sc-ifAKCX jPtpSf"><a href="https://github.com/httptoolkit"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="github" class="svg-inline--fa fa-github fa-w-16 fa-2x " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 496 512"><path fill="currentColor" d="M165.9 397.4c0 2-2.3 3.6-5.2 3.6-3.3.3-5.6-1.3-5.6-3.6 0-2 2.3-3.6 5.2-3.6 3-.3 5.6 1.3 5.6 3.6zm-31.1-4.5c-.7 2 1.3 4.3 4.3 4.9 2.6 1 5.6 0 6.2-2s-1.3-4.3-4.3-5.2c-2.6-.7-5.5.3-6.2 2.3zm44.2-1.7c-2.9.7-4.9 2.6-4.6 4.9.3 2 2.9 3.3 5.9 2.6 2.9-.7 4.9-2.6 4.6-4.6-.3-1.9-3-3.2-5.9-2.9zM244.8 8C106.1 8 0 113.3 0 252c0 110.9 69.8 205.8 169.5 239.2 12.8 2.3 17.3-5.6 17.3-12.1 0-6.2-.3-40.4-.3-61.4 0 0-70 15-84.7-29.8 0 0-11.4-29.1-27.8-36.6 0 0-22.9-15.7 1.6-15.4 0 0 24.9 2 38.6 25.8 21.9 38.6 58.6 27.5 72.9 20.9 2.3-16 8.8-27.1 16-33.7-55.9-6.2-112.3-14.3-112.3-110.5 0-27.5 7.6-41.3 23.6-58.9-2.6-6.5-11.1-33.3 2.6-67.9 20.9-6.5 69 27 69 27 20-5.6 41.5-8.5 62.8-8.5s42.8 2.9 62.8 8.5c0 0 48.1-33.6 69-27 13.7 34.7 5.2 61.4 2.6 67.9 16 17.7 25.8 31.5 25.8 58.9 0 96.5-58.9 104.2-114.8 110.5 9.2 7.9 17 22.9 17 46.4 0 33.7-.3 75.4-.3 83.6 0 6.5 4.6 14.4 17.3 12.1C428.2 457.8 496 362.9 496 252 496 113.3 383.5 8 244.8 8zM97.2 352.9c-1.3 1-1 3.3.7 5.2 1.6 1.6 3.9 2.3 5.2 1 1.3-1 1-3.3-.7-5.2-1.6-1.6-3.9-2.3-5.2-1zm-10.8-8.1c-.7 1.3.3 2.9 2.3 3.9 1.6 1 3.6.7 4.3-.7.7-1.3-.3-2.9-2.3-3.9-2-.6-3.6-.3-4.3.7zm32.4 35.6c-1.6 1.3-1 4.3 1.3 6.2 2.3 2.3 5.2 2.6 6.5 1 1.3-1.3.7-4.3-1.3-6.2-2.2-2.3-5.2-2.6-6.5-1zm-11.4-14.7c-1.6 1-1.6 3.6 0 5.9 1.6 2.3 4.3 3.3 5.6 2.3 1.6-1.3 1.6-3.9 0-6.2-1.4-2.3-4-3.3-5.6-2z"></path></svg></a><a href="https://twitter.com/httptoolkit"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="twitter" class="svg-inline--fa fa-twitter fa-w-16 fa-2x " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path fill="currentColor" d="M459.37 151.716c.325 4.548.325 9.097.325 13.645 0 138.72-105.583 298.558-298.558 298.558-59.452 0-114.68-17.219-161.137-47.106 8.447.974 16.568 1.299 25.34 1.299 49.055 0 94.213-16.568 130.274-44.832-46.132-.975-84.792-31.188-98.112-72.772 6.498.974 12.995 1.624 19.818 1.624 9.421 0 18.843-1.3 27.614-3.573-48.081-9.747-84.143-51.98-84.143-102.985v-1.299c13.969 7.797 30.214 12.67 47.431 13.319-28.264-18.843-46.781-51.005-46.781-87.391 0-19.492 5.197-37.36 14.294-52.954 51.655 63.675 129.3 105.258 216.365 109.807-1.624-7.797-2.599-15.918-2.599-24.04 0-57.828 46.782-104.934 104.934-104.934 30.213 0 57.502 12.67 76.67 33.137 23.715-4.548 46.456-13.32 66.599-25.34-7.798 24.366-24.366 44.833-46.132 57.827 21.117-2.273 41.584-8.122 60.426-16.243-14.292 20.791-32.161 39.308-52.628 54.253z"></path></svg></a><a href="/rss.xml"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="rss-square" class="svg-inline--fa fa-rss-square fa-w-14 fa-2x " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M400 32H48C21.49 32 0 53.49 0 80v352c0 26.51 21.49 48 48 48h352c26.51 0 48-21.49 48-48V80c0-26.51-21.49-48-48-48zM112 416c-26.51 0-48-21.49-48-48s21.49-48 48-48 48 21.49 48 48-21.49 48-48 48zm157.533 0h-34.335c-6.011 0-11.051-4.636-11.442-10.634-5.214-80.05-69.243-143.92-149.123-149.123-5.997-.39-10.633-5.431-10.633-11.441v-34.335c0-6.535 5.468-11.777 11.994-11.425 110.546 5.974 198.997 94.536 204.964 204.964.352 6.526-4.89 11.994-11.425 11.994zm103.027 0h-34.334c-6.161 0-11.175-4.882-11.427-11.038-5.598-136.535-115.204-246.161-251.76-251.76C68.882 152.949 64 147.935 64 141.774V107.44c0-6.454 5.338-11.664 11.787-11.432 167.83 6.025 302.21 141.191 308.205 308.205.232 6.449-4.978 11.787-11.432 11.787z"></path></svg></a></div><div class="sc-EHOje cieZjZ"><a href="/terms-of-service/">Terms of Service</a><a href="/privacy-policy/">Privacy Policy</a><a href="/alternatives/">Comparisons</a></div><div class="sc-gzVnrw bGXQre"><strong>100% open-source</strong><br/>Dive in at <a href="https://github.com/httptoolkit" target="_blank" rel="noopener noreferrer">github.com/httptoolkit</a></div><div class="sc-bZQynM bKLyNE"><img src="data:image/png;base64,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" alt="Picture of Tim Perry" class="sc-htoDjs cWnjEm"/>Built in Barcelona<br/>by <a href="https://twitter.com/pimterry">Tim Perry</a></div></div></main></div><div id="gatsby-announcer" style="position:absolute;top:0;width:1px;height:1px;padding:0;overflow:hidden;clip:rect(0, 0, 0, 0);white-space:nowrap;border:0" aria-live="assertive" aria-atomic="true"></div></div><script>
  
  function gaOptout(){document.cookie=disableStr+'=true; expires=Thu, 31 Dec 2099 23:59:59 UTC;path=/',window[disableStr]=!0}var gaProperty='UA-117670723-1',disableStr='ga-disable-'+gaProperty;document.cookie.indexOf(disableStr+'=true')>-1&&(window[disableStr]=!0);
  if(!(navigator.doNotTrack == "1" || window.doNotTrack == "1")) {
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  }
  if (typeof ga === "function") {
    ga('create', 'UA-117670723-1', 'auto', {});
      ga('set', 'anonymizeIp', true);
      
      
      }
      </script><script type="text/javascript" src="https://cdn.jsdelivr.net/npm/docsearch.js@2/dist/cdn/docsearch.min.js"></script><script type="text/javascript">var observer = new MutationObserver(function (mutations, instance) {
  var docuSearchElem = document.querySelector('.docsearch-input');
  if (docuSearchElem) {
    docsearch({
      apiKey: "f5b49b1ad3229d305c66fc594c1133a3",
      indexName: "httptoolkit",
      inputSelector: ".docsearch-input",
      debug: false
    });
    instance.disconnect(); // stop observing
    return;
  }
});

// start observing
document.addEventListener("DOMContentLoaded", function() {
  observer.observe(document, {
    childList: true,
    subtree: true
  });
});</script><script id="gatsby-script-loader">/*<![CDATA[*/window.pagePath="/docs/guides/docker/";/*]]>*/</script><script id="gatsby-chunk-mapping">/*<![CDATA[*/window.___chunkMapping={"polyfill":["/polyfill-48ba1e77b1d0494f1ef5.js"],"app":["/app-d8ae094ac4221d9a77cf.js"]};/*]]>*/</script><script nomodule src='https://d33wubrfki0l68.cloudfront.net/js/a812b6e166adeadd252ff9815d35f4d5dd6a1c2b/polyfill-48ba1e77b1d0494f1ef5.js'></script><script async src='https://d33wubrfki0l68.cloudfront.net/bundles/71c176bab8616bc89ca851812462e1c9ac83b782.js'></script></body></html>