<!DOCTYPE html><html lang="en"><head><meta charSet="utf-8"/><meta http-equiv="x-ua-compatible" content="ie=edge"/><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"/><style data-href="/styles.d55f0b00584a849e5a53.css" id="gatsby-global-css">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</style><meta name="generator" content="Gatsby 2.32.13"/><style data-styled="snXzu  dHFJiE juhqmw emkjqm gXdVsZ bNBvDS krfJjt dcCAoE bOFCvB hWelvs jVZUeo kbKsWI bxudMK kSqmuK cWnjEm jpiTUM bBznVW cAawdS cdMcph ePJMKg ghinhy kjGRDe IFRKJ dMYDB bSmbcb cuYzWk lmdzyt dkQcXS hOucDX jPtpSf cieZjZ bGXQre bKLyNE" data-styled-version="4.4.1">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</style><style type="text/css">
    .anchor {
      float: left;
      padding-right: 4px;
      margin-left: -20px;
    }
    h1 .anchor svg,
    h2 .anchor svg,
    h3 .anchor svg,
    h4 .anchor svg,
    h5 .anchor svg,
    h6 .anchor svg {
      visibility: hidden;
    }
    h1:hover .anchor svg,
    h2:hover .anchor svg,
    h3:hover .anchor svg,
    h4:hover .anchor svg,
    h5:hover .anchor svg,
    h6:hover .anchor svg,
    h1 .anchor:focus svg,
    h2 .anchor:focus svg,
    h3 .anchor:focus svg,
    h4 .anchor:focus svg,
    h5 .anchor:focus svg,
    h6 .anchor:focus svg {
      visibility: visible;
    }
  </style><script>
    document.addEventListener("DOMContentLoaded", function(event) {
      var hash = window.decodeURI(location.hash.replace('#', ''))
      if (hash !== '') {
        var element = document.getElementById(hash)
        if (element) {
          var offset = element.offsetTop
          // Wait for the browser to finish rendering before scrolling.
          setTimeout((function() {
            window.scrollTo(0, offset - 80)
          }), 0)
        }
      }
    })
  </script><link rel="alternate" type="application/rss+xml" title="HTTP Toolkit RSS Feed" href="/rss.xml"/><title data-react-helmet="true">Android Chrome 99 expands Certificate Transparency, breaking all MitM dev tools | HTTP Toolkit</title><link data-react-helmet="true" rel="preconnect" href="https://cdn.paddle.com"/><link data-react-helmet="true" rel="preconnect" href="https://checkout.paddle.com"/><link data-react-helmet="true" rel="preconnect" href="https://accounts.paddle.com"/><link data-react-helmet="true" rel="preload" href="https://cdn.jsdelivr.net/npm/docsearch.js@2/dist/cdn/docsearch.min.css" as="style"/><link data-react-helmet="true" rel="preload" href="https://cdn.jsdelivr.net/npm/docsearch.js@2/dist/cdn/docsearch.min.js" as="script"/><link data-react-helmet="true" rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png"/><link data-react-helmet="true" rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png"/><link data-react-helmet="true" rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png"/><link data-react-helmet="true" rel="manifest" href="/site.webmanifest"/><link data-react-helmet="true" rel="mask-icon" href="/safari-pinned-tab.svg" color="#e1421f"/><link data-react-helmet="true" rel="alternate" type="application/rss+xml" href="https://httptoolkit.tech/rss.xml"/><meta data-react-helmet="true" name="msapplication-TileColor" content="#da532c"/><meta data-react-helmet="true" name="theme-color" content="#fafafa"/><meta data-react-helmet="true" name="viewport" content="width=device-width, initial-scale=1"/><meta data-react-helmet="true" property="og:url" content="https://httptoolkit.tech/blog/chrome-android-certificate-transparency/"/><meta data-react-helmet="true" property="og:type" content="website"/><meta data-react-helmet="true" name="twitter:site" content="@httptoolkit"/><meta data-react-helmet="true" name="twitter:creator" content="@pimterry"/><meta data-react-helmet="true" name="description" content="Certificate transparency is superb improvement to HTTPS certificate security on the web that&#x27;s great for users and businesses, but on…"/><meta data-react-helmet="true" property="og:title" content="Android Chrome 99 expands Certificate Transparency, breaking all MitM dev tools"/><meta data-react-helmet="true" property="og:description" content="Certificate transparency is superb improvement to HTTPS certificate security on the web that&#x27;s great for users and businesses, but on…"/><meta data-react-helmet="true" property="og:image" content="https://httptoolkit.tech/static/dad31f4452a01458258a797bb0c4174e/3c289/person-behind-mirror.jpg"/><meta data-react-helmet="true" name="twitter:card" content="summary_large_image"/><meta data-react-helmet="true" name="twitter:title" content="Android Chrome 99 expands Certificate Transparency, breaking all MitM dev tools"/><meta data-react-helmet="true" name="twitter:description" content="Certificate transparency is superb improvement to HTTPS certificate security on the web that&#x27;s great for users and businesses, but on…"/><meta data-react-helmet="true" name="twitter:image" content="https://httptoolkit.tech/static/dad31f4452a01458258a797bb0c4174e/3c289/person-behind-mirror.jpg"/><script data-react-helmet="true" type="application/ld+json">{"@context":"https://schema.org","@type":"SoftwareApplication","image":"https://httptoolkit.tech/logo-square.png","screenshot":"https://httptoolkit.tech/screenshot.png","video":"https://httptoolkit.tech/http-mock-demo.mp4","name":"HTTP Toolkit","description":"Beautiful & open-source tools to debug, test and develop with HTTP(S)","softwareVersion":"1.8.1","operatingSystem":["Windows","Mac","Linux","Android"],"url":"https://httptoolkit.tech/","downloadUrl":"https://httptoolkit.tech/","applicationCategory":"DeveloperApplication","offers":{"@type":"Offer","price":"0"}}</script><script data-react-helmet='true' src='https://d33wubrfki0l68.cloudfront.net/js/0a1bbc5c045539aca1eea8d31577fdd8d542c1c6/infobox.js'></script><link rel="preload" as="font" type="font/woff2" crossorigin="anonymous" href="/static/webfonts/s/lato/v23/S6uyw4BMUTPHjx4wXg.woff2"/><link rel="preload" as="font" type="font/woff2" crossorigin="anonymous" href="/static/webfonts/s/merriweather/v30/u-440qyriQwlOrhSvowK_l5-fCZM.woff2"/><style>@font-face{font-display:swap;font-family:Lato;font-style:normal;font-weight:400;src:url("https://d33wubrfki0l68.cloudfront.net/fcd4136085f2a03481d9958cc6793a5ed98e714c/a2f50/static/webfonts/s/lato/v23/s6uyw4bmutphjx4wxg.woff2") format("woff2")}@font-face{font-display:swap;font-family:Lato;font-style:normal;font-weight:400;src:url("https://d33wubrfki0l68.cloudfront.net/a7e64df567e19e9a9be13c97f25b5ab3daf5094e/4719e/static/webfonts/s/lato/v23/s6uyw4bmutphjx4wwa.woff") format("woff")}@font-face{font-display:fallback;font-display:swap;font-family:Merriweather;font-family:Courgette;font-style:normal;font-weight:400;src:url("https://d33wubrfki0l68.cloudfront.net/8effd23e482511e249c3f8e91cdc503729b93598/3ace1/static/webfonts/s/merriweather/v30/u-440qyriqwlorhsvowk_l5-fczm.woff2") format("woff2");src:url("https://d33wubrfki0l68.cloudfront.net/a2437c174ac713d5989658163e8b5d8d97d98ffa/f88b6/static/webfonts/l/font") format("woff2")}@font-face{font-display:fallback;font-family:Merriweather;font-style:normal;font-weight:400;src:url("https://d33wubrfki0l68.cloudfront.net/be26c6cac90095764e04954b1e49f8e7aeeb6ab4/58a8c/static/webfonts/s/merriweather/v30/u-440qyriqwlorhsvowk_l5-fczk.woff") format("woff")}@font-face{font-display:swap;font-family:Courgette;font-style:normal;font-weight:400;src:url("https://d33wubrfki0l68.cloudfront.net/a2437c174ac713d5989658163e8b5d8d97d98ffa/f88b6/static/webfonts/l/font") format("woff")}</style><link rel="preconnect dns-prefetch" href="https://www.google-analytics.com"/><link rel="sitemap" type="application/xml" href="/sitemap.xml"/><link rel="canonical" href="https://httptoolkit.tech/blog/chrome-android-certificate-transparency/" data-baseprotocol="https:" data-basehost="httptoolkit.tech"/><link rel="stylesheet" href="https://cdn.jsdelivr.net/npm/docsearch.js@2/dist/cdn/docsearch.min.css"/><link as="script" rel="preload" href="/webpack-runtime-71e046241d7d5cdf707d.js"/><link as="script" rel="preload" href="/framework-c5dc0716c0b2bd661fa9.js"/><link as="script" rel="preload" href="/styles-c4fa86dfd4ad05097eee.js"/><link as="script" rel="preload" href="/d2ec3f50-41b428099539d861b764.js"/><link as="script" rel="preload" href="/9e82d048-dda34e6b7cc3a92e58bf.js"/><link as="script" rel="preload" href="/app-d293e10010f29ff0e65f.js"/><link as="fetch" rel="preload" href="/page-data/blog/chrome-android-certificate-transparency/page-data.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/page-data/app-data.json" crossorigin="anonymous"/></head><body><div id="___gatsby"><div style="outline:none" tabindex="-1" id="gatsby-focus-wrapper"><main class="sc-kAzzGY snXzu"><div class="sc-bdVaJa dHFJiE"><div class="sc-bwzfXH juhqmw"><div class="sc-htpNat emkjqm"><a class="sc-chPdSV gXdVsZ" href="/"><img src="https://d33wubrfki0l68.cloudfront.net/bf336c12f88430c817226c3a390b970ab29ea5ac/d4a5d/static/logo-5658def669bc8a94ba3d97f752342bd4.svg" alt="HTTP Toolkit"/></a><a href="#menu" class="sc-kGXeez bNBvDS"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="bars" class="svg-inline--fa fa-bars fa-w-14 fa-2x " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M16 132h416c8.837 0 16-7.163 16-16V76c0-8.837-7.163-16-16-16H16C7.163 60 0 67.163 0 76v40c0 8.837 7.163 16 16 16zm0 160h416c8.837 0 16-7.163 16-16v-40c0-8.837-7.163-16-16-16H16c-8.837 0-16 7.163-16 16v40c0 8.837 7.163 16 16 16zm0 160h416c8.837 0 16-7.163 16-16v-40c0-8.837-7.163-16-16-16H16c-8.837 0-16 7.163-16 16v40c0 8.837 7.163 16 16 16z"></path></svg></a><nav id="menu" class="sc-kgoBCf krfJjt"><button class="sc-fjdhpX bOFCvB sc-kpOJdX dcCAoE"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="times" class="svg-inline--fa fa-times fa-w-11 fa-2x " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 352 512"><path fill="currentColor" d="M242.72 256l100.07-100.07c12.28-12.28 12.28-32.19 0-44.48l-22.24-22.24c-12.28-12.28-32.19-12.28-44.48 0L176 189.28 75.93 89.21c-12.28-12.28-32.19-12.28-44.48 0L9.21 111.45c-12.28 12.28-12.28 32.19 0 44.48L109.28 256 9.21 356.07c-12.28 12.28-12.28 32.19 0 44.48l22.24 22.24c12.28 12.28 32.2 12.28 44.48 0L176 322.72l100.07 100.07c12.28 12.28 32.2 12.28 44.48 0l22.24-22.24c12.28-12.28 12.28-32.19 0-44.48L242.72 256z"></path></svg></button><a class="sc-dxgOiQ hWelvs" href="/docs/">Docs</a><a class="sc-dxgOiQ hWelvs" href="/pricing/">Pricing</a><a class="sc-dxgOiQ hWelvs" href="/blog/">Blog</a><a class="sc-dxgOiQ hWelvs" href="/contact/">Contact</a></nav></div></div></div><section width="780px" class="sc-ckVGcZ sc-drMfKT jVZUeo"><article class="sc-hIVACf kbKsWI"><div class="sc-gpHHfC bxudMK gatsby-image-wrapper" style="position:relative;overflow:hidden"><div style="width:100%;padding-bottom:31.71875%"></div><img src="data:image/jpeg;base64,/9j/2wBDABALDA4MChAODQ4SERATGCgaGBYWGDEjJR0oOjM9PDkzODdASFxOQERXRTc4UG1RV19iZ2hnPk1xeXBkeFxlZ2P/2wBDARESEhgVGC8aGi9jQjhCY2NjY2NjY2NjY2NjY2NjY2NjY2NjY2NjY2NjY2NjY2NjY2NjY2NjY2NjY2NjY2NjY2P/wgARCAAGABQDASIAAhEBAxEB/8QAFQABAQAAAAAAAAAAAAAAAAAAAAP/xAAWAQEBAQAAAAAAAAAAAAAAAAADAgT/2gAMAwEAAhADEAAAAbTFw2FB/8QAGBAAAwEBAAAAAAAAAAAAAAAAAAECESH/2gAIAQEAAQUCvJKakcd//8QAFxEAAwEAAAAAAAAAAAAAAAAAARAREv/aAAgBAwEBPwHIi//EABURAQEAAAAAAAAAAAAAAAAAABAR/9oACAECAQE/Aaf/xAAYEAEAAwEAAAAAAAAAAAAAAAABABBBYf/aAAgBAQAGPwIHYHa//8QAGhAAAgIDAAAAAAAAAAAAAAAAAREAITFRYf/aAAgBAQABPyEFa3schKwsBjcRH//aAAwDAQACAAMAAAAQ/C//xAAYEQEAAwEAAAAAAAAAAAAAAAABABFRsf/aAAgBAwEBPxAcNZ2IXP/EABURAQEAAAAAAAAAAAAAAAAAABEA/9oACAECAQE/EEzf/8QAGxABAAIDAQEAAAAAAAAAAAAAAQARITFBYYH/2gAIAQEAAT8QTdQRyoc+wBWKWDYN37DQxjE//9k=" alt="" style="position:absolute;top:0;left:0;width:100%;height:100%;object-fit:cover;object-position:center;opacity:1;transition-delay:500ms"/><noscript><picture><source type='image/webp' srcset="https://d33wubrfki0l68.cloudfront.net/0de044139b22641e6e004a4fb067e8b5ce6a8052/7b185/static/dad31f4452a01458258a797bb0c4174e/97a54/person-behind-mirror.webp 640w,
https://d33wubrfki0l68.cloudfront.net/3eee9a3cf9950ee9791c012db0d20bb5f4a23cc4/59dc2/static/dad31f4452a01458258a797bb0c4174e/fad22/person-behind-mirror.webp 1280w,
https://d33wubrfki0l68.cloudfront.net/dae3f47b14e9a5b81c4c32e4f0a012ec76510123/fff03/static/dad31f4452a01458258a797bb0c4174e/d829f/person-behind-mirror.webp 2000w" sizes="(max-width: 2000px) 100vw, 2000px" /><source srcset="https://d33wubrfki0l68.cloudfront.net/8b34a72e05ac2bfb5c098b91a75f0419795f5bc2/db521/static/dad31f4452a01458258a797bb0c4174e/b67a5/person-behind-mirror.jpg 640w,
https://d33wubrfki0l68.cloudfront.net/09e5bc7dd10a558efd918838a10867632be953da/7d0ab/static/dad31f4452a01458258a797bb0c4174e/684d9/person-behind-mirror.jpg 1280w,
https://d33wubrfki0l68.cloudfront.net/48507da87299e79477e8cb9d857228dca43dc32e/ab584/static/dad31f4452a01458258a797bb0c4174e/469fe/person-behind-mirror.jpg 2000w" sizes="(max-width: 2000px) 100vw, 2000px" /><img loading="eager" sizes="(max-width: 2000px) 100vw, 2000px" srcset="https://d33wubrfki0l68.cloudfront.net/8b34a72e05ac2bfb5c098b91a75f0419795f5bc2/db521/static/dad31f4452a01458258a797bb0c4174e/b67a5/person-behind-mirror.jpg 640w,
https://d33wubrfki0l68.cloudfront.net/09e5bc7dd10a558efd918838a10867632be953da/7d0ab/static/dad31f4452a01458258a797bb0c4174e/684d9/person-behind-mirror.jpg 1280w,
https://d33wubrfki0l68.cloudfront.net/48507da87299e79477e8cb9d857228dca43dc32e/ab584/static/dad31f4452a01458258a797bb0c4174e/469fe/person-behind-mirror.jpg 2000w" src="https://d33wubrfki0l68.cloudfront.net/48507da87299e79477e8cb9d857228dca43dc32e/ab584/static/dad31f4452a01458258a797bb0c4174e/469fe/person-behind-mirror.jpg" alt="" style="position:absolute;top:0;left:0;opacity:1;width:100%;height:100%;object-fit:cover;object-position:center"/></picture></noscript></div><h1>Android Chrome 99 expands Certificate Transparency, breaking all MitM dev tools</h1><div><p>Certificate transparency is superb improvement to HTTPS certificate security on the web that's great for users and businesses, but on Android it creates a huge problem for the many developer tools like <strong><a href="https://httptoolkit.tech">HTTP Toolkit</a></strong> which install trusted system certificates into Android to intercept &#x26; debug app traffic.</p>
<p>This doesn't appear in the main announcements anywhere, but buried deep in the enterprise <a href="https://support.google.com/chrome/a/answer/7679408#certTrans&#x26;zippy=%2Cchrome">release notes</a> for Chrome v99 there's a small note that says:</p>
<blockquote>
<p>Certificate transparency is already enforced on desktop platforms, and for some Android users. Chrome 99 expands certificate transparency to all Android Chrome users.</p>
</blockquote>
<p>And with that small note, Chrome on Android become uninterceptable for all HTTP Toolkit users using rooted devices, and anybody else who actively installs and trusts their own system CA certificates.</p>
<p>If you're running into an <code class="language-text">ERR_CERTIFICATE_TRANSPARENCY_REQUIRED</code> error in Chrome while trying to debug your HTTPS traffic with some MitM debugging proxy, then this affecting you too.</p>
<p>Let's talk about how certificate transparency works, why this breaks, and how you can work around it to keep debugging HTTPS from Chrome on your Android device regardless.</p>
<h2 id="certificate-transparency-ct"><a href="#certificate-transparency-ct" aria-label="certificate transparency ct permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Certificate Transparency (CT)</h2>
<p>HTTPS certificates are issued and signed by Certificate Authorities (CAs) who are trusted by your browser &#x26; OS.</p>
<p>That's great when it works, but sometimes it doesn't. CAs can make mistakes when issuing certificates, when verifying a client's identity beforehand, or through malice somewhere, and issue fraudulent certificates to people who shouldn't have them.</p>
<p>For example, let's say a trusted CA issues a certificate for google.com to the wrong person (this <a href="https://security.googleblog.com/2011/08/update-on-attempted-man-in-middle.html">actually happened</a>, <a href="https://security.googleblog.com/2015/09/improved-digital-certificate-security.html">repeatedly</a>). That issued certificate is incredibly powerful - whoever has it can freely intercept all traffic sent by anybody to Google.com and both see &#x26; modify that traffic, whilst browsers will show all users a padlock and tell them everything is totally fine &#x26; secure.</p>
<p>Even worse though: attacks like this were invisible. In the past, if you managed to get such a certificate and started doing targeted interception of Google.com somewhere, you could keep doing so almost indefinitely. Unless you really slip up or you intercept somebody who's checking for this very very closely, nobody will ever know.</p>
<p>Certificate Transparency aims to solve this, by allowing domain owners to be aware of all valid certificates ever issued for their domain, and thereby ensuring any misissued certificates can be spotted and revoked immediately. It works (very roughly) like this:</p>
<ul>
<li>Some independent organizations host certificate logs (CT logs), which immutably (via <a href="https://en.wikipedia.org/wiki/Merkle_tree">merkle trees</a>) record the details of issued TLS certificates, and let people query these logs.</li>
<li>When a CA issues a new certificate, it submits the details to one or more of these log providers, receiving an signed certificate timestamp (SCT) signed by the provider.</li>
<li>The CA sends the certificate with the SCT embedded back to their client (e.g. a person hosting a web service who wants a certificate for HTTPS).</li>
<li>The CA's client serves all their HTTPS traffic using this certificate.</li>
<li>Browsers receiving this traffic enforce that all certificates they receive come with a matching SCT, signed by a log provider they trust.</li>
</ul>
<p>SCTs effectively act as a receipt, proving that you have submitted your certificate to a trusted log provider and so that its existence is public knowledge. By requiring an SCT at the browser level, you're guaranteeing that certificates must be publicly recorded to be usable. That means anybody can query the public logs to see the full list of valid certificates that have been issued for their domain, and can set up warning system to immediately know if any certificates are ever issued unexpectedly.</p>
<p>This makes it very very difficult to issue fraudulent certificates for a domain without publicly announcing it in a CT log.</p>
<h2 id="certificate-transparency-meets-mitm-debugging-proxies"><a href="#certificate-transparency-meets-mitm-debugging-proxies" aria-label="certificate transparency meets mitm debugging proxies permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Certificate Transparency meets MitM debugging proxies</h2>
<p><a href="https://en.wikipedia.org/wiki/Man-in-the-middle_attack">MitM proxies</a> like HTTP Toolkit sit between an HTTP or HTTPS client and the server they want to talk to, and proxy the traffic, so that it can be inspected and modified. These are popular tools for developers, testers, security/privacy researchers &#x26; reverse engineers. For most software, a lot of important interactions involve HTTP(S) and being able to see and poke that traffic directly is very powerful.</p>
<p>To do this for HTTPS, these proxies basically issue fraudulent certificates for the domains being intercepted, with the cooperation of the HTTPS client (by configuring the client or the OS itself to trust the proxy's certificate) so that they're accepted.</p>
<p>Although it sounds like CT should block this, it's not actually intended to - by design, it only applies to public root certificates, not to manually trusted self-signed certificates, or it would make all self-signed certificates impossible to use, breaking everything from enterprise intranet sites to local HTTPS development servers.</p>
<p>It's these self-signed certificates that MitM proxies use to intercept traffic, so this shouldn't be an issue, and on Chrome on desktop it's not. The MitM certificate is installed into the OS trust store manually, or trusted explicitly via Chrome flags, and the certificate transparency requirements aren't applied.</p>
<p>That is, not until Chrome 99 was released on Android.</p>
<h2 id="certificate-transparency-in-chrome-99-on-android"><a href="#certificate-transparency-in-chrome-99-on-android" aria-label="certificate transparency in chrome 99 on android permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Certificate Transparency in Chrome 99 on Android</h2>
<p>On Android, there are a few different certificate stores (full details <a href="https://httptoolkit.tech/blog/intercepting-android-https/#android-certificate-stores">here</a>). You can install your own CA certificates to intercept HTTPS traffic on Android, but intercepting any interesting traffic from an app that isn't explicitly opting-in to interception requires you to put your certificate into the 'system' store, not just the normal 'user' store.</p>
<p>Almost all apps will trust the CAs from this system store to issue certificates for HTTPS. That means if you can put your MitM proxy of choice's CA certificate there, then your proxy can intercept all those app's HTTPS, and you can immediately see what traffic any app is sending, and test out what it does with alternate responses. This is great! Writing to the system store is only possible on rooted devices and emulators, but that's fairly standard for reverse engineering work, and many developers &#x26; testers have rooted devices too so they can do the same with production builds, or to modify other system settings.</p>
<p>The problem though is that Chrome's condition for what it considers to be a public root certificate (and so subject to certificate transparency requirements) is just whether it's in the system store or the user store. The system store is widely used for self-signed certificates like this, but as soon as you put your certificate in there, suddenly everything issued by your little testing CA must be formally submitted to a CT log and served up with an SCT proving it's been published publicly.</p>
<p>That means that since Chrome 99 was released until I shipped a fix (just now), when you used HTTP Toolkit on a rooted device Chrome threw loud <code class="language-text">NET::ERR_CERTIFICATE_TRANSPARENCY_REQUIRED</code> errors on every single HTTPS page, like so:</p>
<p><span
      class="gatsby-resp-image-wrapper"
      style="position: relative; display: block; margin-left: auto; margin-right: auto; max-width: 338px; "
    >
      <a
    class="gatsby-resp-image-link"
    href="/static/3641d6212d60ed9ec177b732a841017c/d362c/chrome-android-certificate-transparency-error.png"
    style="display: block"
    target="_blank"
    rel="noopener"
  >
    <span
    class="gatsby-resp-image-background-image"
    style="padding-bottom: 178.57142857142856%; position: relative; bottom: 0; left: 0; background-image: url('data:image/png;base64,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'); background-size: cover; display: block;"
  ></span>
  <img
        class="gatsby-resp-image-image"
        alt="Chrome showing a certificate transparency error for example.com"
        title="Chrome showing a certificate transparency error for example.com"
        src="https://d33wubrfki0l68.cloudfront.net/b07518440e768eca31c459f351785a4f4411b9ce/eacd6/static/3641d6212d60ed9ec177b732a841017c/d362c/chrome-android-certificate-transparency-error.png"
        srcset="https://d33wubrfki0l68.cloudfront.net/1a85a96c1af0c566d3907e27051b4df3698609eb/091f3/static/3641d6212d60ed9ec177b732a841017c/ddeaf/chrome-android-certificate-transparency-error.png 84w,
https://d33wubrfki0l68.cloudfront.net/ebabb11e81898f8b7ae20ab38a197ac4c2cabbaa/89b61/static/3641d6212d60ed9ec177b732a841017c/f4dcd/chrome-android-certificate-transparency-error.png 169w,
https://d33wubrfki0l68.cloudfront.net/46e4087cf37e1755a2a00fc2d743f0fa3383501c/12b0e/static/3641d6212d60ed9ec177b732a841017c/2a8de/chrome-android-certificate-transparency-error.png 338w,
https://d33wubrfki0l68.cloudfront.net/b07518440e768eca31c459f351785a4f4411b9ce/eacd6/static/3641d6212d60ed9ec177b732a841017c/d362c/chrome-android-certificate-transparency-error.png 356w"
        sizes="(max-width: 338px) 100vw, 338px"
        style="width:100%;height:100%;margin:0;vertical-align:middle;position:absolute;top:0;left:0;"
        loading="lazy"
      />
  </a>
    </span></p>
<p>This applies to all MitM web debugging proxies. If you put your certificate in the system store so you can intercept app traffic, then you can't intercept Chrome v99+. If you put your certificate in the user store to intercept Chrome, then you can't intercept anything <em>except</em> Chrome. (And no, you can't do both: if the certificate's in the system store at all, then certificate transparency is mandatory and it's game over). Very inconvenient!</p>
<h2 id="how-to-fix-it"><a href="#how-to-fix-it" aria-label="how to fix it permalink" class="anchor"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>How to Fix It</h2>
<p>First up, it'd be great if Chrome fixed this themselves, by treating user-installed system certificates differently to the built-in root certificates. I've filed <a href="https://bugs.chromium.org/p/chromium/issues/detail?id=1324303">a Chromium bug</a> suggesting that, but I'm not holding my breath - despite the popular use case, I suspect they'll likely consider adding your own system certificates as officially unsupported, and an acceptable casualty for the benefits of certificate transparency. We'll see though (feel free to star that bug if this is interesting to you too).</p>
<p>In the meantime, there is a way to work around this: you can manually modify the flags used by Chrome, to explicitly trust your specific CA certificate, in addition to installing it the system store, thereby disabling certificate transparency checks.</p>
<p>You can do this using the <code class="language-text">--ignore-certificate-errors-spki-list=&lt;cert hash></code> option. This is available on all platforms, but it's a bit tricky to set on Android, since you don't directly control how Chrome starts up. To enable this, you need to:</p>
<ul>
<li>
<p>Get the SPKI fingerprint of your certificate. You can do so using this OpenSSL magic incantation:</p>
<div class="gatsby-highlight" data-language="text">
      <pre class="language-text"><code class="language-text">openssl x509 -in $YOUR_CA_CERTIFICATE -pubkey -noout | openssl pkey -pubin -outform der | openssl dgst -sha256 -binary | openssl enc -base64</code></pre>
      </div>
</li>
<li>
<p>Create a file containing one line:</p>
<p><code class="language-text">chrome --ignore-certificate-errors-spki-list=$YOUR_SPKI_FINGERPRINT</code></p>
</li>
<li>
<p>Use <code class="language-text">adb push</code> to store this on your Android device at:</p>
<ul>
<li><code class="language-text">/data/local/chrome-command-line</code></li>
<li><code class="language-text">/data/local/android-webview-command-line</code></li>
<li><code class="language-text">/data/local/webview-command-line</code></li>
<li><code class="language-text">/data/local/content-shell-command-line</code></li>
<li><code class="language-text">/data/local/tmp/chrome-command-line</code></li>
<li><code class="language-text">/data/local/tmp/android-webview-command-line</code></li>
<li><code class="language-text">/data/local/tmp/webview-command-line</code></li>
<li><code class="language-text">/data/local/tmp/content-shell-command-line</code></li>
</ul>
<p>This ensures it applies for all varieties of Chromium, in both normal &#x26; debug environments. You'll need root access to set the non-tmp files, which is what's used on production devices (while the <code class="language-text">tmp</code> files are used by userdebug builds).</p>
</li>
<li>Set the permissions of each the above with <code class="language-text">chmod 555 &lt;filename></code> to ensure that it's readable by Chromium when it starts.</li>
<li>Force stop Chrome (<code class="language-text">am force-stop com.android.chrome</code>), and then open it again.</li>
<li>Check the command line flags shown on <code class="language-text">chrome://version</code> to ensure this command line option is included there.</li>
</ul>
<p>Not convenient at all, but not the worst workaround in the world, and although it requires root in many cases, this only affects rooted devices &#x26; emulators so that's no big deal.</p>
<p>This is now integrated into HTTP Toolkit as part of the automated ADB setup in the latest release, so if you're using a rooted device with HTTP Toolkit this will work for you automatically in future! Of course, if you do still have problems do please <a href="https://github.com/httptoolkit/httptoolkit/issues/new">file an issue</a>.</p>
<p><strong>Want to take your Android reverse engineering to the next level? <a href="https://httptoolkit.tech/android/">HTTP Toolkit</a> gives you one-click HTTP(S) interception, inspection &#x26; mocking for any Android app.</strong></p></div><p title="May 11th 2022" class="sc-fgfRvd kSqmuK"><span>Published <!-- -->2 days ago<!-- --> by <a href="https://twitter.com/pimterry">Tim Perry</a></span><img src="data:image/png;base64,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" alt="Picture of Tim Perry" class="sc-htoDjs cWnjEm"/></p></article><div class="sc-gVyKpa jpiTUM"><a class="sc-eXNvrr bBznVW" title="Share this post on Twitter" href="https://twitter.com//intent/tweet?text=Android Chrome 99 expands Certificate Transparency, breaking all MitM dev tools&amp;url=https://httptoolkit.tech/blog/chrome-android-certificate-transparency/" target="_blank" rel="noopener noreferrer"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="twitter" class="svg-inline--fa fa-twitter fa-w-16 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path fill="currentColor" d="M459.37 151.716c.325 4.548.325 9.097.325 13.645 0 138.72-105.583 298.558-298.558 298.558-59.452 0-114.68-17.219-161.137-47.106 8.447.974 16.568 1.299 25.34 1.299 49.055 0 94.213-16.568 130.274-44.832-46.132-.975-84.792-31.188-98.112-72.772 6.498.974 12.995 1.624 19.818 1.624 9.421 0 18.843-1.3 27.614-3.573-48.081-9.747-84.143-51.98-84.143-102.985v-1.299c13.969 7.797 30.214 12.67 47.431 13.319-28.264-18.843-46.781-51.005-46.781-87.391 0-19.492 5.197-37.36 14.294-52.954 51.655 63.675 129.3 105.258 216.365 109.807-1.624-7.797-2.599-15.918-2.599-24.04 0-57.828 46.782-104.934 104.934-104.934 30.213 0 57.502 12.67 76.67 33.137 23.715-4.548 46.456-13.32 66.599-25.34-7.798 24.366-24.366 44.833-46.132 57.827 21.117-2.273 41.584-8.122 60.426-16.243-14.292 20.791-32.161 39.308-52.628 54.253z"></path></svg></a><a class="sc-cpmKsF cAawdS" title="Share this post on Reddit" href="http://www.reddit.com//submit?url=https://httptoolkit.tech/blog/chrome-android-certificate-transparency/" target="_blank" rel="noopener noreferrer"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="reddit-alien" class="svg-inline--fa fa-reddit-alien fa-w-16 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path fill="currentColor" d="M440.3 203.5c-15 0-28.2 6.2-37.9 15.9-35.7-24.7-83.8-40.6-137.1-42.3L293 52.3l88.2 19.8c0 21.6 17.6 39.2 39.2 39.2 22 0 39.7-18.1 39.7-39.7s-17.6-39.7-39.7-39.7c-15.4 0-28.7 9.3-35.3 22l-97.4-21.6c-4.9-1.3-9.7 2.2-11 7.1L246.3 177c-52.9 2.2-100.5 18.1-136.3 42.8-9.7-10.1-23.4-16.3-38.4-16.3-55.6 0-73.8 74.6-22.9 100.1-1.8 7.9-2.6 16.3-2.6 24.7 0 83.8 94.4 151.7 210.3 151.7 116.4 0 210.8-67.9 210.8-151.7 0-8.4-.9-17.2-3.1-25.1 49.9-25.6 31.5-99.7-23.8-99.7zM129.4 308.9c0-22 17.6-39.7 39.7-39.7 21.6 0 39.2 17.6 39.2 39.7 0 21.6-17.6 39.2-39.2 39.2-22 .1-39.7-17.6-39.7-39.2zm214.3 93.5c-36.4 36.4-139.1 36.4-175.5 0-4-3.5-4-9.7 0-13.7 3.5-3.5 9.7-3.5 13.2 0 27.8 28.5 120 29 149 0 3.5-3.5 9.7-3.5 13.2 0 4.1 4 4.1 10.2.1 13.7zm-.8-54.2c-21.6 0-39.2-17.6-39.2-39.2 0-22 17.6-39.7 39.2-39.7 22 0 39.7 17.6 39.7 39.7-.1 21.5-17.7 39.2-39.7 39.2z"></path></svg></a><a class="sc-gPzReC ePJMKg" title="Share this post on Hacker News" href="https://news.ycombinator.com/submitlink?u=https://httptoolkit.tech/blog/chrome-android-certificate-transparency/" target="_blank" rel="noopener noreferrer"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="hacker-news" class="svg-inline--fa fa-hacker-news fa-w-14 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M0 32v448h448V32H0zm21.2 197.2H21c.1-.1.2-.3.3-.4 0 .1 0 .3-.1.4zm218 53.9V384h-31.4V281.3L128 128h37.3c52.5 98.3 49.2 101.2 59.3 125.6 12.3-27 5.8-24.4 60.6-125.6H320l-80.8 155.1z"></path></svg></a></div><div class="sc-ibxdXY IFRKJ"><div class="sc-eXEjpC dMYDB"><strong>Become an HTTP &amp; debugging expert</strong> by subscribing to receive <!-- -->more posts like this<!-- --> emailed straight to your inbox:<form action="https://tech.us18.list-manage.com/subscribe/post?u=f6e81ee3f567741ec9800aa56&amp;id=001b24c3da&amp;SOURCE=blog:subscribe" method="post" target="_blank" novalidate="" class="sc-iAyFgw bSmbcb"><input type="email" name="EMAIL" placeholder="Enter your email" title="Enter your email to stay up to date with new blog posts &amp; updates" value="" class="sc-dnqmqq cuYzWk"/><div style="position:absolute;left:-5000px"><input type="text" name="b_f6e81ee3f567741ec9800aa56_001b24c3da" tabindex="-1" aria-hidden="true" value=""/></div><input type="submit" value="Subscribe" name="subscribe" class="sc-gZMcBi lmdzyt"/><p class="sc-kkGfuU dkQcXS">No spam, just new blog posts hot off the press</p></form></div></div></section><div class="sc-bxivhb hOucDX"><div class="sc-ifAKCX jPtpSf"><a href="https://github.com/httptoolkit"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="github" class="svg-inline--fa fa-github fa-w-16 fa-2x " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 496 512"><path fill="currentColor" d="M165.9 397.4c0 2-2.3 3.6-5.2 3.6-3.3.3-5.6-1.3-5.6-3.6 0-2 2.3-3.6 5.2-3.6 3-.3 5.6 1.3 5.6 3.6zm-31.1-4.5c-.7 2 1.3 4.3 4.3 4.9 2.6 1 5.6 0 6.2-2s-1.3-4.3-4.3-5.2c-2.6-.7-5.5.3-6.2 2.3zm44.2-1.7c-2.9.7-4.9 2.6-4.6 4.9.3 2 2.9 3.3 5.9 2.6 2.9-.7 4.9-2.6 4.6-4.6-.3-1.9-3-3.2-5.9-2.9zM244.8 8C106.1 8 0 113.3 0 252c0 110.9 69.8 205.8 169.5 239.2 12.8 2.3 17.3-5.6 17.3-12.1 0-6.2-.3-40.4-.3-61.4 0 0-70 15-84.7-29.8 0 0-11.4-29.1-27.8-36.6 0 0-22.9-15.7 1.6-15.4 0 0 24.9 2 38.6 25.8 21.9 38.6 58.6 27.5 72.9 20.9 2.3-16 8.8-27.1 16-33.7-55.9-6.2-112.3-14.3-112.3-110.5 0-27.5 7.6-41.3 23.6-58.9-2.6-6.5-11.1-33.3 2.6-67.9 20.9-6.5 69 27 69 27 20-5.6 41.5-8.5 62.8-8.5s42.8 2.9 62.8 8.5c0 0 48.1-33.6 69-27 13.7 34.7 5.2 61.4 2.6 67.9 16 17.7 25.8 31.5 25.8 58.9 0 96.5-58.9 104.2-114.8 110.5 9.2 7.9 17 22.9 17 46.4 0 33.7-.3 75.4-.3 83.6 0 6.5 4.6 14.4 17.3 12.1C428.2 457.8 496 362.9 496 252 496 113.3 383.5 8 244.8 8zM97.2 352.9c-1.3 1-1 3.3.7 5.2 1.6 1.6 3.9 2.3 5.2 1 1.3-1 1-3.3-.7-5.2-1.6-1.6-3.9-2.3-5.2-1zm-10.8-8.1c-.7 1.3.3 2.9 2.3 3.9 1.6 1 3.6.7 4.3-.7.7-1.3-.3-2.9-2.3-3.9-2-.6-3.6-.3-4.3.7zm32.4 35.6c-1.6 1.3-1 4.3 1.3 6.2 2.3 2.3 5.2 2.6 6.5 1 1.3-1.3.7-4.3-1.3-6.2-2.2-2.3-5.2-2.6-6.5-1zm-11.4-14.7c-1.6 1-1.6 3.6 0 5.9 1.6 2.3 4.3 3.3 5.6 2.3 1.6-1.3 1.6-3.9 0-6.2-1.4-2.3-4-3.3-5.6-2z"></path></svg></a><a href="https://twitter.com/httptoolkit"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="twitter" class="svg-inline--fa fa-twitter fa-w-16 fa-2x " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path fill="currentColor" d="M459.37 151.716c.325 4.548.325 9.097.325 13.645 0 138.72-105.583 298.558-298.558 298.558-59.452 0-114.68-17.219-161.137-47.106 8.447.974 16.568 1.299 25.34 1.299 49.055 0 94.213-16.568 130.274-44.832-46.132-.975-84.792-31.188-98.112-72.772 6.498.974 12.995 1.624 19.818 1.624 9.421 0 18.843-1.3 27.614-3.573-48.081-9.747-84.143-51.98-84.143-102.985v-1.299c13.969 7.797 30.214 12.67 47.431 13.319-28.264-18.843-46.781-51.005-46.781-87.391 0-19.492 5.197-37.36 14.294-52.954 51.655 63.675 129.3 105.258 216.365 109.807-1.624-7.797-2.599-15.918-2.599-24.04 0-57.828 46.782-104.934 104.934-104.934 30.213 0 57.502 12.67 76.67 33.137 23.715-4.548 46.456-13.32 66.599-25.34-7.798 24.366-24.366 44.833-46.132 57.827 21.117-2.273 41.584-8.122 60.426-16.243-14.292 20.791-32.161 39.308-52.628 54.253z"></path></svg></a><a href="/rss.xml"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="rss-square" class="svg-inline--fa fa-rss-square fa-w-14 fa-2x " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M400 32H48C21.49 32 0 53.49 0 80v352c0 26.51 21.49 48 48 48h352c26.51 0 48-21.49 48-48V80c0-26.51-21.49-48-48-48zM112 416c-26.51 0-48-21.49-48-48s21.49-48 48-48 48 21.49 48 48-21.49 48-48 48zm157.533 0h-34.335c-6.011 0-11.051-4.636-11.442-10.634-5.214-80.05-69.243-143.92-149.123-149.123-5.997-.39-10.633-5.431-10.633-11.441v-34.335c0-6.535 5.468-11.777 11.994-11.425 110.546 5.974 198.997 94.536 204.964 204.964.352 6.526-4.89 11.994-11.425 11.994zm103.027 0h-34.334c-6.161 0-11.175-4.882-11.427-11.038-5.598-136.535-115.204-246.161-251.76-251.76C68.882 152.949 64 147.935 64 141.774V107.44c0-6.454 5.338-11.664 11.787-11.432 167.83 6.025 302.21 141.191 308.205 308.205.232 6.449-4.978 11.787-11.432 11.787z"></path></svg></a></div><div class="sc-EHOje cieZjZ"><a href="/terms-of-service/">Terms of Service</a><a href="/privacy-policy/">Privacy Policy</a><a href="/alternatives/">Comparisons</a></div><div class="sc-gzVnrw bGXQre"><strong>100% open-source</strong><br/>Dive in at <a href="https://github.com/httptoolkit" target="_blank" rel="noopener noreferrer">github.com/httptoolkit</a></div><div class="sc-bZQynM bKLyNE"><img src="data:image/png;base64,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" alt="Picture of Tim Perry" class="sc-htoDjs cWnjEm"/>Built in Barcelona<br/>by <a href="https://twitter.com/pimterry">Tim Perry</a></div></div></main></div><div id="gatsby-announcer" style="position:absolute;top:0;width:1px;height:1px;padding:0;overflow:hidden;clip:rect(0, 0, 0, 0);white-space:nowrap;border:0" aria-live="assertive" aria-atomic="true"></div></div><script>
  
  function gaOptout(){document.cookie=disableStr+'=true; expires=Thu, 31 Dec 2099 23:59:59 UTC;path=/',window[disableStr]=!0}var gaProperty='UA-117670723-1',disableStr='ga-disable-'+gaProperty;document.cookie.indexOf(disableStr+'=true')>-1&&(window[disableStr]=!0);
  if(!(navigator.doNotTrack == "1" || window.doNotTrack == "1")) {
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  }
  if (typeof ga === "function") {
    ga('create', 'UA-117670723-1', 'auto', {});
      ga('set', 'anonymizeIp', true);
      
      
      }
      </script><script type="text/javascript" src="https://cdn.jsdelivr.net/npm/docsearch.js@2/dist/cdn/docsearch.min.js"></script><script type="text/javascript">var observer = new MutationObserver(function (mutations, instance) {
  var docuSearchElem = document.querySelector('.docsearch-input');
  if (docuSearchElem) {
    docsearch({
      apiKey: "f5b49b1ad3229d305c66fc594c1133a3",
      indexName: "httptoolkit",
      inputSelector: ".docsearch-input",
      debug: false
    });
    instance.disconnect(); // stop observing
    return;
  }
});

// start observing
document.addEventListener("DOMContentLoaded", function() {
  observer.observe(document, {
    childList: true,
    subtree: true
  });
});</script><script id="gatsby-script-loader">/*<![CDATA[*/window.pagePath="/blog/chrome-android-certificate-transparency/";/*]]>*/</script><script id="gatsby-chunk-mapping">/*<![CDATA[*/window.___chunkMapping={"polyfill":["/polyfill-48ba1e77b1d0494f1ef5.js"],"app":["/app-d293e10010f29ff0e65f.js"]};/*]]>*/</script><script nomodule src='https://d33wubrfki0l68.cloudfront.net/js/a812b6e166adeadd252ff9815d35f4d5dd6a1c2b/polyfill-48ba1e77b1d0494f1ef5.js'></script><script async src='https://d33wubrfki0l68.cloudfront.net/bundles/fd68d58c4de2ee8b261be2d85c47ba43a7f3495c.js'></script></body></html>